1

I'm trying to login to my Azure VM with my AAD credentials (login with Azure AD already enabled while creating the VM), a RBAC as " virtual machine administrator login " is also already assigned to this VM. im trying to login with RDP and with this form: username: AzureAD\username@work-domain.com password: my-password But i receive this error message : "The Sign-in method you're trying to use isn't allowed. For more info, contact network administrator". can anyone help?

note: i have already tryed with GPO but it didn't help out

3
  • Did you figure this out? Having the same issue. So far all that works is NOT enabling azure ad at build time and manually joining the machine. – D3l_Gato Jun 28 '20 at 2:23
  • yes it works but under one condition: you have to disable the multi factor authentication for the user you want to sign in, if this not an option for you, you have then to use a smart login methode link windows hello. – jorg-m Jun 28 '20 at 11:06
  • You should post this answer!!! Thanks so much. – D3l_Gato Jun 28 '20 at 15:56
1

so that was my solution: it works but under one condition: you have to disable the multi factor authentication for the user you want to sign in, if this not an option for you or you do not want to do this for a reason, you have then to use a smart login methode link windows hello, please see this for more informations : https://docs.microsoft.com/en-us/azure/active-directory/devices/howto-vm-sign-in-azure-ad-windows

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.