0

I am facing this problem where there is an error while I try to install filezilla3. So as I wanted to install it offline, I used sftp to transfer FileZilla3 zip file from another computer that has internet, I have successfully unzip the file but when I tried to run there is this error.

vncuser2@osboxes:~$ ls Desktop Pictures Documents Public Downloads Templates FileZilla3 Videos FileZilla_3.47.2.1_x86_64-linux-gnu.tar.bz2 VNC-Server-6.7.1-Linux-x64.deb Music

vncuser2@osboxes:~$ cd FileZilla3

vncuser2@osboxes:~/FileZilla3$ ls bin lib share

vncuser2@osboxes:~/FileZilla3$ cd bin

vncuser2@osboxes:~/FileZilla3/bin$ ls filezilla fzputtygen fzsftp fzstorj

vncuser2@osboxes:~/FileZilla3/bin$ ./filezilla ./filezilla: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Or is there a better way for me to install filezilla, please, help me out thank you!

0

You probably want to download the packages on another PC - and make sure to check sure you have the packages you need. apt depends will tell you what you need

geek@test-box:/var/crash$ apt depends filezilla
filezilla
  Depends: filezilla-common (= 3.39.0-2)
  Depends: libc6 (>= 2.28)
  Depends: libdbus-1-3 (>= 1.9.14)
  Depends: libfilezilla0 (>= 0.15.1)
  Depends: libgcc1 (>= 1:3.0)
  Depends: libglib2.0-0 (>= 2.12.0)
  Depends: libgnutls30 (>= 3.6.5)
  Depends: libgtk2.0-0 (>= 2.10.0)
  Depends: libnettle6
  Depends: libpugixml1v5 (>= 1.7)
  Depends: libsqlite3-0 (>= 3.5.9)
  Depends: libstdc++6 (>= 5.2)
  Depends: libwxbase3.0-0v5 (>= 3.0.4+dfsg)
  Depends: libwxgtk3.0-0v5 (>= 3.0.4+dfsg)

I'm lazy so I'd run apt install -s filezilla and grab the list of files from there.

apt has a download only option - you can download the debs for these packages with

apt download filezilla-common libfilezilla0 libgail-common libgail18 libgtk2.0-0 libgtk2.0-bin libgtk2.0-common libpugixml1v5 libwxbase3.0-0v5 downloads all these to the current directory.

You can copy these over, and if a file is missing, you can install the relevant package with dpkg.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.