0

When I try to search for a filename, I've recently started getting "No items match your search" when I try to find files with names that match. This used to work fine and I'm not sure when it stopped working, but I think it was within the past couple months.

I tried rebuilding the Windows search index days ago but that didn't solve it. I also tried upgrading from Windows 10 version 1809 to 1909 but that didn't solve it either.

  • Make sure Windows 10 is fully up to date. There were V1909 updates available to fix Search. Then open cmd.exe with Run as Administrator and run both: (1) dism.exe /online /cleanup-image /restorehealth followed by (2) SFC /SCANNOW . Restart when both have finished, rebuild your Search Index (make sure Search Locations (Users and Outlook, and others) are correct before re-indexing. – John Mar 20 at 16:37
2

Try this ways:

Search and Indexing Troubleshooter

  • Press Windows key + R

  • Type in Control Panel and press Enter

  • In the Control Panel search box type in Troubleshoot

  • Then click Troubleshooting > View all

  • Select Search and Indexing and click Next

  • Let Troubleshooter run and fix all your search problems automatically

Note if you have not indexed your computer's search locations then index them. Also if run does not work then open cmd and run command control.exe to open Control Panel.

Restart Win10 virtual assistant Cortana

  • Open Task manager (Opening cmd and running command taskmgr or run Ctrl+Shift+Esc

  • Scroll down and find Cortana in the list

  • Click 'End Task'

Rebuild Indexing services

  • Click on Start button and go to All Apps

  • Scroll down to Windows System and click on Control Panel

  • Select the Small Icon View and choose Indexing Options

  • Select Advanced and then click on Rebuild

  • When Warning pops up click OK.

Check If windows search service is running

  • go to Control Panel > Administrative Tools and double-click on Services

  • Scroll down to find Windows Search and double-click it

  • Pick Automatic under the General tab > Startup type

  • Press Start, then Apply and finally OK (note: If Windows Search is enabled, make sure you restart it by right-clicking on it and pressing Restart).

Pick the Always search file names and contents option

  • Open File Explorer and pick View tab

  • Click on Options button and then press Change folder and search options on the menu

This link has helped me: https://ugetfix.com/ask/how-to-fix-file-explorer-error-no-items-match-your-search-in-windows-10/

| improve this answer | |
  • +1 for a thorough answer which I think will likely help others. Unfortunately none of these solved it for me – g491 Mar 20 at 19:22
  • Did you try the suggestions I laid out for you above? – John Mar 20 at 19:41
  • Please read How to reference material written by others. **You must block quote text that has been written by some else. ** – DavidPostill Mar 20 at 21:16
  • OK, how do you block quote? – Moab Mar 20 at 21:23
0

The cause was that somehow both hard drives had been unchecked from Control Panel -> Indexing Options -> Modify.

Checking those and then rebuilding the index in Control Panel -> Indexing Options -> Advanced resolved the issue.

Thanks @John who suggested making sure the locations were checked in a comment on the question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.