2

I'm using vim with the solarized dark color scheme within the Windows Subsystem for Linux. Solarized looks great except for one strange feature. When I scroll down in a vim file and then scroll back up, the empty space at the ends of the lines that were hidden when I scrolled down are highlighted in a distracting red color.

image

I have an imperfect workaround. By running :set background=dark within vim, the red highlighting temporarily goes away, but I am looking for a more permanent solution.

Here is the relevant section of my .vimrc file:

 syntax enable
 set background=dark
 let g:solarized_termcolors=256
 colorscheme solarized 

I installed vim from altercation/vim-colors-solarized repository using the manual installation. Any help would be greatly appreciated.

1

I think I found a solution. Following the instructions posted here, I added set t_ut="" to my .vimrc file.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.