0

I've had an annoyance for a while when visiting websites in Chrome that use the Palatino font: lowercase y and z don't show at all, and lowercase x shows as a double quote ("). I just tried installing Firefox, and it does the same. Safari, however, renders the font correctly.

Chrome's rendered fonts utility shows that the font is from a local file. I've tried using the atsutil utility to delete the font cache with no success. Font Book shows the font correctly, and applications like TextEdit can use it with no issues.

I've had this problem for several years, at least back to El Capitan (I'm on Catalina 10.15.2). It's been a low-level annoyance all this time. I'd like to fix it, but have no idea why only Chrome and Firefox would have the problem in the first place.

How do I resolve this?

0

I don't use Chrome, but I know that a setting in Firefox allows you to use or not web fonts in webpages. Sometimes, unchecking the option, restarting Firefox, then re-enabling the option will purge the web font cache and load a clean set of fonts.

Alternately, you can download the font from the editor's website and install it manually (it'll detect your OS automatically, unless you're using a script blocker such as NoScript or ScriptSafe; if you do, you'll have to authorize the whole page).

EDIT: you did use the "sudo atsutil databases -remove" command to clear the system font cache, didn't you? It requires admin rights.

  • Yes, I did use atsutil as you said. I also had no other windows besides Terminal open, and restarted my Mac immediately afterwards. – Jay Maynard K5ZC Mar 21 '20 at 13:08
  • I tried again, just to confirm: close all windows, open a Terminal window, issue sudo atsutil databases -remove (which said it removed two files), then restart. Still corrupted. – Jay Maynard K5ZC Mar 21 '20 at 14:38
  • Tried to boot in Safe Mode? Just boot it up, wait until all system processes are up and running, then reboot normally. Sometimes that's enough to clear corrupted system caches. Otherwise, you can also clear your other browsers cache entirely. Maybe that's where the problem lies. Finally, you ca use AppleJack (macupdate.com/app/mac/15667/applejack), though it's lost a lot of functionalities since the advent of macOS (it was designed for OS X), it can still perform basic cleaning tasks on macOS in Single User Mode. Worth a try, won't hurt your Mac. – user1019780 Mar 21 '20 at 15:16
  • I'm running a patched Catalina on my Mac Pro 5,1, which won't start in safe mode...which I only learned after trying it. This problem's not related to the patch, though, as it happened in previous versions of macOS. – Jay Maynard K5ZC Mar 21 '20 at 16:16
  • I were you, I'd try AppleJack in Single User mode (press Command-S on startup til you reach the prompt). Once there, type "applejack AUTO restart" (no quotes, AUTO in caps), wait til AJ is done, it'll reboot your Mac, but depending on the amount of data in your system and apps caches, virtual memory and the like, it could take some time. Repairing permissions won't work, so AJ will skip it altogether, though it'll pretend to do it. Like I said, can't hurt. – user1019780 Mar 21 '20 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.