0

Audio simply stopped working for VLC (& other video players). MacOS 10.14.6, VLC 3.0.8. Audio is fine otherwise; YouTube has audio, games in Steam do too, my music player works fine. I've checked all the obvious settings in Preferences, it should be working. But it's not. I reinstalled VLC & tried using an alternate video player. No audio. Not for videos (any format: mp4, avi, etc), mp3's or streaming audio via icecast. mp3's play fine in my mp3 player though.

So, any ideas on where the fault lies?

5
  • have you checked the sound settings for per-app sound preferences? maybe you accidentally pressed a hotkey to mute the program for some reason. Although reinstalling should reset that so its a shot in the dark.
    – QuickishFM
    Commented Mar 22, 2020 at 16:31
  • 1
    @QuickishFM - Reinstalling apps does not reset their settings [very common misconception, but unfortunately rife]. VLC's output device is controlled by VLC itself on Mac. Check the audio menu & your regular Sound control panel, aso see if Utilities/Audio Midi setup has anything unusual.
    – Tetsujin
    Commented Mar 22, 2020 at 18:48
  • I did check VLC's Prefs, can see nothing that might cause this there. Also I cannot get audio from other video players which makes me suspect it's a codec or library issue rather than app specific. All other audio is unaffected by this - browser, mp3 player, system sounds, games all play fine. Can't see anything unusual in Midi.
    – scalefree
    Commented Mar 22, 2020 at 19:41
  • What happened is still a mystery but VLC has audio again! I see no reason to keep this open, there's no problem to solve anymore.
    – scalefree
    Commented Mar 22, 2020 at 22:09
  • Hi I just ran into the same problem on Linux and found a solution that worked for me, could you remove the "macos" related tags?
    – insaner
    Commented Mar 31, 2021 at 3:18

1 Answer 1

0

I just had this same problem but on Linux, where VLC suddenly stopped playing audio on certain files, which worked on other players, like Xine (I thought it might be related to the files being MP4 using AAC as the codec, but all posted solutions to this that I tried yielded no success). After trying with a different file, and noticing no audio on that, on a hunch, I clicked in the top menu where it says "Audio" and then "Track" and noticed that the track option was disabled. Selecting "Track 1" solved it, but upon restarting the file, it would go back to the "disabled" option for some reason. After some trial and error I found the solution to be as follows:

In the top menu, go to Tools > Preferences, and at the bottom, where it says "Show settings" select "all" to give you the advanced settings options. Then on the left, find Input / Codecs and click on that, and in the first section, labelled "Track settings", go to the option which says "Audio track ID" and select "1" then click on the bottom button that says "Save". It should work right away.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .