0

I have forwarded the port 5900 for TightVNC. I have TightVNC 2.0 Beta4 installed on my Windows Vista machine.

I then try to connect from an Arch Linux box:

[earlz@earlzarch ~]$ vncviewer somehost::5900
Connected to RFB server, using protocol version 3.8
Performing standard VNC authentication
Password:
Authentication successful
vncviewer: VNC server closed connection
[earlz@earlzarch ~]$ vncviewer --help
TightVNC Viewer version 1.3.10

What is wrong here? I thought that TightVNC 2.0 fixed the Vista bug with VNC servers? Is there any additional configuration I needed?

Update I've tried from my LAN connecting with the TightVNC beta4 client and it yields an "IPv4 Error". I then tried uninstalling the TightVNC server and installing UltraVNC. When connecting to UltraVNC with TightVNC viewer, I get the same exact error. When connecting to UltraVNC with UltraVNC's own client I get "connection closed: server running as application".

I have absolutely no idea why I would have so much trouble getting a simple VNC server running. I am running 64bit Windows Vista, have no firewall installed(and Windows Firewall disabled)

  • Post your config – Daisetsu Jun 17 '10 at 5:07
  • Have you tried using the Beta 4 Windows client? – stukelly Jun 17 '10 at 13:25
  • @stuk No I have not.. @Dais it's safe to assume it is the complete defaults. I haven't done any configuration except for setting passwords after installing – Earlz Jun 17 '10 at 15:38
1

Finally found the problem, RealVNC.

I had to install it for some reason a few months ago to get the viewer. Apparently it doesn't ask or anything if you want to also install the server, so it did. The (non-working) RealVNC server hence listened on all the ports instead of TightVNC or UltraVNC.

Disabled the RealVNC server service and fixed all my problems

  • For the record: RealVNC's viewer installer is now separate, so you can install it easily without the server. – Nicholas Wilson Nov 7 '12 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.