0

I have an iPhone X with hotspot connected to Win7 via USB and the PC is connected to an Asus AC2900 RT-AC86U router via LAN cable. I have tried to go through the share data with your router setup via PC. If I use the bridge connections between LAN (the router) and LAN 3 (the phone) then

enter image description here

The network bridge starts up and the phone hotspot shares data with the PC as usual

enter image description here

With the Bridge Status showing the IPv4 Connectivity as Internet. However, if another PC now connects to the Router there is no internet bridge via the Router. The LAN status shows the IPv4 as Not Connected.

enter image description here

Funnily enough the Phone connection also shows as Not Connected even though the hotspot works:

enter image description here

What can I do to get the internet connection to share via this method? THANKS

1

Why not use ICS (Internet Connection Sharing) instead of a bridged connection? It works way better, especially with that kind of setup.

Right-click on your Local Area Network 3 icon, choose Properties, go to the Sharing tab, and check the Share this connection box (the other option isn't necessary). You'll be good to go in a matter of seconds, because Windows will know you want to share this iPhone connection with the other available network adapter, namely your Ethernet port.

| improve this answer | |
  • thanks, though unfortunately this happens – rupweb Mar 23 at 17:02
  • 1
    Oh, have you read this news about the latest iOS update breaking Hotspot on several models of iPhone? See this, among other articles: any-data-recovery.com/fix-iphone/… EDIT: it's just to explain that a recent iOS update may have broken Hotspot on your phone altogether, not an invitation to purchase any products. I'll try to find more unbiased material and post if here for you...EDIT #2: techradar.com/news/… – user1019780 Mar 23 at 18:08
  • Per this answer I had to set up the router as an access point and then the internet connection sharing started working. – rupweb Mar 23 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.