1

I have two 240 GB SSDs and two 2.0 TB HDDs in a Lenovo ThinkStation D30 Type 4353 bought refurbished two years ago. In trying to boot Windows 10 my PC from a USB flash drive, it sees no media at all.

enter image description here

I can see all my drivers when I am with Ubuntu, but not when I try to boot Windows 10. Here is a little picture when I run sudo fdisk -l :

Image 2

Windows installation calling for driver

I asked this question because during the installation I got that error. Here's more data:

$ lsblk | grep -v "loop" && df -h | grep -v loop
NAME    MAJ:MIN RM  SIZE    RO  TYPE    MOUNTPOINT 
sda     8:0      0  223.6G   0  disk
 Lsda1  8:1      0  223.6G   0  part    /
sdb     8:16     0  1.8T     0  disk
sdc     8:32     0  1.8T     0  disk
 Lsdc1  8:33     0  1.4T     0  part
sdd     8:48     0  223.6G   0  disk
 Lsdd1  8:49     0    55M    0  part
sde     8:64     0  1.8T     0  disk
 Lsde1  8:65     0  9.3G     0  part    /media/jeremie/Win10Update
sr0     11:0     1  1024M    0  rom

How can I fix it so that I can see at least my two SSDs? Do you have an idea of the logical boot sequence here?

Boot device selection after POST

  • 2
    You probably need the appropriate driver for whatever controller the SSDs and HDDs are connected to. Linux should be able to tell you with the output of lspci or something like that. (Or look inside and see what the drives are connected to.) – David Schwartz Mar 23 '20 at 23:00
  • 1
    @DavidSchwartz I have already used controllers today, i.e. one from IBM and the other from Intel, but none of them worked for me. To be honest, I worked all day in trying to find the solution, but I have no positive answers yet. – J.Doe Mar 23 '20 at 23:06
  • 1
    Did you load the appropriate Windows drivers for those controllers? Notice there's a "Load Driver" option at the bottom of that window. – David Schwartz Mar 23 '20 at 23:07
  • 1
    I used ibm_dd_sraidmr_6.702.07.00-2_windows_32-64.exe, i.e. ibm.com/support/pages/… and that one downloadcenter.intel.com/download/29350/…. Can you tell me if both of them were fine? I think they are good, but maybe I am wrong – J.Doe Mar 23 '20 at 23:10
  • 1
    @DavidSchwartz Do you need information with lspci? I can certainly provide them to you, but there's too much info – J.Doe Mar 23 '20 at 23:12
1

Here's your after Power-On Self Test Boot Options screen and my best suggestions regarding what they are:

enter image description here

USB Key: USB DISK 2.0 PMAP is what's on the USB flash drive
|- Legacy: USB Disk 2.0 PMAP is the EFI partition of the USB flash drive
L_ UEFI: USB Disk 2.0 PMAP is the GPT partition of the USB flash drive
SCU Device 1: Micron_M500_MTFDDAK240MAV is one of your SSDs
SCU Device 2: Intel Volume0 looks like a RAID configuration of the 1.8 TB HDDs
SCU Device 3: KINGSTON SA400S37240G is your other SSD
SATA 0: MATSHITA DVD-RAM SW830 is your DVD drive
Network 1: IBA GE Slot 00c8 v1372 is your LAN adapter for PCE boot use

SCU Device 2 looks like a RAID configuration never removed from those drives. I would remove those drives, then try to install to SCU Device 1. Once that works, then move ahead in small steps, such as adding the Kingston SSD, then breaking up the RAID pairing of those 1.8 TB drives and adding them back in.

And, as Tonny wisely noted in a comment, go into the BIOS/Firmware settings and make sure Legacy/CSM Support is disabled there.

  • 1
    I think you are on the right track. A leftover of a previous raid-config can confuse Windows and not bother Linux at all. I would also recommend the disable "Legacy/CSM" support in the Bios. That might account for the bogus extra disk. – Tonny Mar 25 '20 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.