1

I am trying to set up access to a Windows 10 share from Ubuntu 18.04.

I get the following error:

Unable to mount location

Failed to retrieve share list from server: Connection timed out

The error comes immediately as I click the Windows 10 computer name in the Files window of my Ubuntu. (For comparison, if another Windows 7 computer on the same network is not on, the error comes with a delay.)

What I did:

  1. I have the following lines in my etc/samba/smb.conf per https://ubuntuforums.org/showthread.php?t=2390873&p=13764895#post13764895 :

    workgroup = WORKGROUP

    client max protocol = NT1

  2. On Windows 10, I did Step 1 of https://websiteforstudents.com/quickly-enable-file-sharing-between-windows-10-and-ubuntu-17-04-17-10/ .

  3. I checked that Windows 10 Firewall has a rule for File and Printer Sharing (SMB-In) with the following description: Inbound rule for File and Printer Sharing to allow Server Message Block transmission and reception via Named Pipes [TCP 445]. It is enabled to allow the connection. It is set for Domain, Public and Private networks. It has Protocol Type = TCP, Protocol number = 6, Local Port = Specific ports, 445. Remote port = All ports.

I do not want to use explicit IP addresses because my router assigns them dynamically.

I have another Windows 10 computer on the same network, and when I try to access it from Ubuntu, it asks for username and password. (I do not need to share it so I do not continue.)

I have another Windows 7 computer on the same network, and I can access its shares from Ubuntu. I can also access from it the shares on the Windows 10 (the one I cannot access from Ubuntu).

Many thanks for any ideas.

3
  • Is this Windows 10 OS on the same drive as Ubuntu (dual-boot) or on another machine?
    – user1019780
    Mar 24, 2020 at 10:23
  • No, it is a different machine. My understanding that if it is a dual boot then I have direct access to all Windows files from Ubuntu. Mar 24, 2020 at 13:03
  • Not out of the box, at least not every time. It's a bit of a lottery, really, but basically, you must disable Fast Boot in Windows to unlock the NTFS volume where your data is stored, in the case of a dual-boot. Glad to know you solved your actual problem!
    – user1019780
    Mar 24, 2020 at 14:42

2 Answers 2

1

You must allow / force Ubuntu to use a higher protocol version for the SMB-protocol - since Windows 7 at least Microsoft retired by default the old SMB1 protocol and introduced SMB2 / SMB3 ... Windows 10 extends on that principle and by standard enforces SMB3 which leaves you 2 choices :

  1. Enforce SMB1 (insecure according to Microsoft) on the Windows 10 machine
  2. Configure your Ubuntu to work with SMB3 instead of SMB1

Here is a complete description and examples https://fitzcarraldoblog.wordpress.com/2016/10/17/a-correct-method-of-configuring-samba-for-browsing-smb-shares-in-a-home-network/

According to the linked article you need to allow more ports in your firewall - as not only 445 but also 137, 138 and 139 - and probably more ports are involved (new SMB3 relies heavily on NetBios hence 137...139 )

What you wrote about the Windows 7 machine where its "working" - makes me assume that you set that one to use SMB1 - then it would be the easier step to force the Windows 10 machine to do the same ... Unfortunately Linux seems unable to automatically choose the needed SMB protocol from the demands of the target machine

0

The answer of eagle275 worked for me but only after I did some additional research that I am posting here.

I enabled SMB1 on my Windows 10 machine following the first way given in https://winaero.com/blog/enable-smb1-sharig-protocol-windows-10/.

Besides enabling SMB 1.0/CIFS Client as suggested in that post, I had to enable also SMB 1.0/CIFS Server and SMB 1.0/CIFS Automatic Removal. (I did not check whether only one of these two would have been sufficient.)

In addition, I restarted not only Windows 10 machine but also the Ubuntu.

After that things worked!

1
  • Glad you got it working for your machines
    – eagle275
    Mar 24, 2020 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.