0

I installed a Windows 10 Virtual Machine. I enabled Network Adapter, Attached to : Bridged Adapter, Name : wlp6s0. I also installed the VirtualBox Extension Pack. The problem is I can't access the networks on my VM. I installed bash/ubuntu on my VM and with iwconfig, I obtained No Wireless Extension. How can I fix that?

  • It's a virtual wired NIC, not a wireless one. – gronostaj Mar 24 '20 at 13:34
  • @gronostaj Can you extend your answer? I am really not a specialist with VMs. – J.Doe Mar 24 '20 at 13:35
  • Sorry, I don't have enough knowledge about your situation nor enough time to type a proper answer. This hint should point you in the right direction. – gronostaj Mar 24 '20 at 13:38
  • Go to the Virtual Box settings for your guest machine and ensure it has been set for NAT or Bridged - your choice. Then in the guest machine, go to the Network Settings and see if the wired setting works. That is normally true for any guest machine. – John Mar 24 '20 at 14:23
0

when you use NAT or Bridge connections , most hypervisors virtualize connection as wired connection for guest os. you can configure it as a simple LAN (it's not a wifi connection!).
If you want to have a wireless connection Insert a new physical media like a wireless USB adaptor directly to your guest OS, then configure it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.