0

I have two computers. The OS of the first one is Ubuntu and I am using a Windows VM (VirtualBox) on the second computer. I use a Bridge Adapter with the VM. Right now I am able to ping the VM, but if I want to SSH, I got port 22: Connection Refused. Be aware that the firewall is off on the VM. I also installed Bash/Ubuntu on that VM so that I can use Linux command lines. openssh-server is preinstalled when I installed Bash/Ubuntu.

I tried to connect to my VM with ssh username@ip_address.

In that scenario, what is the best way to SSH the Windows 10 VM from Ubuntu?

UPDATE

enter image description here

Actually, I can SSH from my Win10 VM to Ubuntu, but not the opposite.

enter image description here

In the Settings > Apps, OpenSSH-Client and OpenSSh-Server are already installed :

enter image description here

  • in order to diagnose this issue, you must supply, the exact command you are using to establish the SSH connection. – Ramhound Mar 24 '20 at 17:14
  • 1
    Have you enabled the OpenSSH server on Windows 10? – Michael Harvey Mar 24 '20 at 17:52
  • Is there a firewall rule allowing SSH? – Michael Harvey Mar 24 '20 at 18:17
  • Rule allowing SSH has been deactivated? Then no SSH. Or firewall deactivated? – Michael Harvey Mar 24 '20 at 18:23
  • Is OpenSSH starting at Windows 10 start? – Michael Harvey Mar 24 '20 at 18:24
1

You need to enable the Windows 10 OpenSSH server, not the Ubuntu (WSL) one. Follow the steps on this page:

https://docs.microsoft.com/en-us/windows-server/administration/openssh/openssh_install_firstuse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.