1

I recently started working from home full-time (as everyone else here, thanks to Covid-19), and I noticed the following strange behavior when remote-controlling my work PC via RDP:

Sometimes, the RDP window will just stop showing screen updates, as if the remote screen were "frozen". It looks like the RDP session is stuck, but it isn't:

  • After reconnecting, I can see that all the keyboard and mouse events I sent after the screen froze have been processed.
  • The mouse cursor still changes according to what is really underneath: If I drag and drop a window a few centimeters, the window will still be shown at the old position, but the cursor changes to the "resize" cursor when I hover over the new position of the border of the window.

It's not a temporary network issue either:

  • If I wait, the screen just stays frozen (I tried it for many minutes while writing this question).
  • If I close the RDP session and reconnect, everything works fine again (until it freezes again at some random time).

Switching from full-screen to windowed mode and vice versa doesn't help. It looks like a bug in the RDP client or server (both machines are Windows 10 1909).

Is it a known issue? Is there some known workaround (except for closing and reconnecting)?

  • Open Windows 10 RDP. Then see and click on More Options. Go through the tabs and ensure settings in each tab are correct. This is not a bug in Windows 10 RDP so far as I know and use. I assume you are right up to date with Windows 10 V1909. – John Mar 25 at 15:42
  • 1
    You seem to have a problem with your bitmap cache on the client side. Try to toggle the "Permanently cache bitmap" (or something like that; my version is in French) option in the Experience tab. – Didier Mar 25 at 15:47
  • Also, you can try to enable smart sizing (hit the program icon in the top-left of the window to get the menu, and enable smart-sizing. Now resize the window so the screen is forced to refresh. – LPChip Mar 25 at 15:59
  • Many services like RDP are getting their bandwidth squeezed by the providers due to the covid outbreak. YouTube is only allowing lower resolution viewing as an example. – Moab Mar 25 at 17:30
  • @Didier: Good idea! Unfortunately, the issue still occurs in both scenarios (option on and off). – Heinzi Mar 26 at 12:22
0

This seems to be an issue with using UDP in the latest version of windows. The answer in the question linked below worked for me.

Remote Desktop intermittently freezing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.