As the title says I'm not able to make Chrome open magnet URL in uTorrent anymore. I'm on Windows 10 and using the latest uTorrent and Chrome version. The problem started when I first visited https://instant.io/ and accidentally click on "Accept" when it asked if I wanted to let him manage magnet.

What I already tried after searching for fixes:

without success. I downloaded Firefox and it asked me to choose an application when I clicked on a magnet, selected uTorrent and it works. So I'm sure it's a Chrome problem.


NOTE1: the magnet doesn't open in instant.io website, it doesn't open at all, nothing happens when I click it

NOTE2: James Carlyle-Clarke's solution (last superuser link provided) makes the browser open a new window when I click on the magnet, but nothing happens anyway

  • I have exactly the same problem as OP caused by visiting instant.io. None of the fixes worked, same as OP. It's not the user profile because I tried with another user profile and it still did not work.
    – fred
    Apr 3, 2021 at 1:40

4 Answers 4


This question had the same issue except with qbittorrent caused by trying to associate magnet links with a remote client in Chrome. Chrome has set itself as the only program capable of opening magnet links. You can see this by opening Windows 10 Settings > Apps > Default Apps > "Choose default apps by protocol". There is an entry for magnet links, that only has Chrome as an option.

Instead of associating with magnet links via HKEY_CLASSES_ROOT/magnet entry Chrome uses the newer URLAssociations. I don't know about µtorrent, but qbittorrent does not have a URLAssociations entry. Windows seems to prioritize applications with a valid URLAssociations entry over the HKEY_CLASSES_ROOT entry for said protocol.


To fix it, open regedit, navigate to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\Google Chrome\Capabilities\URLAssociations and delete the "magnet" entry.

  • that worked like charm... thanks :) Nov 15, 2021 at 9:14

Your Chrome user profile is corrupted. You can validate this by either

a) Creating a new Windows user and using Chrome to launch a new torrent with a magnet link when logged in as that user, or

b) installing Chromium for your existing user using any other numerous methods described in that link; do not import anything from Chrome when Chromium offers.

Now that we've confirmed where the problem lies, you can continue using Chromium for torrent magnet links, or delete your Chrome user profile. Backup your bookmarks first, though, and save your list of passwords, before you do that.

  • Ok I'll try one of these solutions asap
    – user651908
    Mar 26, 2020 at 17:07

i fix that right now.

Just click with right button on magnet icon, choose open link with


  • Unfortunately this doesn't work :c
    – user651908
    Jun 9, 2020 at 12:19
  • Didn't work for me either. I don't have that choose open link with option.
    – fred
    Apr 3, 2021 at 1:39

A little late, but answering for others that may experience the same problem where nothing seems to work. I experienced the same thing with Chrome not opening magnet links - the only difference is that I was using qBittorrent. After trying every suggestion I found, the only solution that worked for me was uninstalling and reinstalling Chrome. Before doing this, I had also tried uninstalling and reinstalling qBittorrent which may or may not have helped. But after reinstalling Chrome I was able to once again set the default app for magnet links and get them to open in qBittorrent.

You must log in to answer this question.