0

I want to change the tool which is used in Win10 to open PDFs. It's no problem to select my prefered one in the file explorer and use it as default. But I noticed that Outlook doesn't care about this. When I do a double click on a PDF which is send by mail to me, Outlook uses Edge to open it. How can I force Outlook to use my prefered PDF reader?

  • Open Settings then Apps, in the left column you should find Default Apps click on this. On the right hand pane, on the bottom of the links find and choose Choose Default Apps By Filetype – vssher Mar 26 at 8:45
  • Thats what happens when I set the default app via file explorer. The default app for PDFs is set to my prefered tool, but Outlook still ignores it. I also rebooted the system several times since i changed the PDF reader. Nothing helps – roli Mar 26 at 8:50
  • If you have any experience with the Windows Registry find (in the Root section) .pdf and remove instance(s) of outlook. (You might have to trace a CLSID or two). If you do Not have any experience with the Registry I would suggest you Do Not Touch It. – vssher Mar 26 at 8:54
  • Make sure you restart outlook after you set the default app. If that does not do it, assign .PDF to open with any other program, such as notepad, then switch it back to what you want to use, then restart outlook and try again. – LPChip Mar 26 at 9:11
  • I restarted Outlook as well as the computer several times since i set the new default app – roli Mar 26 at 9:12
0

One way of stopping Edge from hijacking the .pdf association is this way:

  • Use regedit to navigate to the key

    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.MicrosoftEdge_44.18362.449.0_neutral__8wekyb3d8bbwe\MicrosoftEdge\Capabilities\FileAssociations
    

    The package name may change with future releases, but it will always start with Microsoft.MicrosoftEdge.

  • Note the value of the .pdf item, which is currently AppXd4nrz8ff68srnhf9t5a8sbjyar1cr723

  • Navigate to the key
    HKEY_CURRENT_USER\Software\Classes\AppXd4nrz8ff68srnhf9t5a8sbjyar1cr723

  • Right-click the key AppXd4nrz8ff68srnhf9t5a8sbjyar1cr723 and rename it, for example by appending an under-score (_) to be able to undo this in the future

  • Use the Default Applications tool of Windows Control Panel to set the default application for PDF files.

  • Reboot.

|improve this answer|||||
  • I followed the instrucktions, but edge still comes up when opening a pdf from Outlook. But the icon for the attached file in Outlook has changed. Prior it was a PDF icon, now it's the edge icon. – roli Mar 26 at 12:54
  • That shouldn't be happening. Try in Control Panel > Programs and Features to right-click Microsoft Office and choose Change to repair. – harrymc Mar 26 at 13:24
  • even after a reboot, outlook sttill opens PDFs via edge :-( – roli Mar 30 at 7:22
  • Microsoft keeps on sabotaging these things. Check Outlook File > Options > Trust Centre > Trust Centre Settings > Attachment Handling > Attachment and Document Previewers to see if you have a PDF preview handler that should be unchecked. – harrymc Mar 30 at 8:17
  • no, there are handlers form many/any MS-Office file types, but none for PDFs – roli Mar 30 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.