0

I just upgraded to Catalina, and now my System Preferences icon in the Dock shows an update badge with an annoying little “1” in it:

Dock with annoying badge

So far, so similar to this old question. Unlike that question, though, when I open up System Preferences, the Software Update icon has the same update badge, so I can at least see where the Dock icon is getting its badge from:

System Preferences with Software Update badge

When I actually click on Software Update, though – surprise, surprise! – there are no updates available (last checked today at 9:43, which is ten minutes ago):

No updates available!

Update settings are set to be as automatic as possible:

Advanced update settings

The contents of com.apple.SoftwareUpdate.plist are:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>AutomaticCheckEnabled</key>
    <true/>
    <key>AutomaticDownload</key>
    <true/>
    <key>AutomaticallyInstallMacOSUpdates</key>
    <true/>
    <key>ConfigDataInstall</key>
    <true/>
    <key>CriticalUpdateInstall</key>
    <true/>
    <key>LastAttemptBuildVersion</key>
    <string>10.15.4 (19E266)</string>
    <key>LastAttemptSystemVersion</key>
    <string>10.15.4 (19E266)</string>
    <key>LastBackgroundSuccessfulDate</key>
    <date>2020-03-26T12:47:19Z</date>
    <key>LastFullSuccessfulDate</key>
    <date>2020-03-26T12:47:05Z</date>
    <key>LastRecommendedMajorOSBundleIdentifier</key>
    <string>com.apple.InstallAssistant.Catalina</string>
    <key>LastRecommendedUpdatesAvailable</key>
    <integer>0</integer>
    <key>LastResultCode</key>
    <integer>2</integer>
    <key>LastSessionSuccessful</key>
    <true/>
    <key>LastSuccessfulDate</key>
    <date>2020-03-26T12:47:05Z</date>
    <key>LastUpdatesAvailable</key>
    <integer>0</integer>
    <key>PrimaryLanguages</key>
    <array>
        <string>en-GB</string>
    </array>
    <key>RecommendedUpdates</key>
    <array/>
    <key>SkipLocalCDN</key>
    <false/>
</dict>
</plist>

(Note that LastUpdatesAvailable is 0, as you’d expect it to be.)

So why is the main screen in System Preferences convinced that there are updates available, even deluding my Dock icon into believing it too? Is there some preference file or cache somewhere that I can delete/flush to make System Preferences reevaluate this existential crisis it seems to be going through?

  • What do you see in the Advanced window? Is your Mac set to automatically dowload updates and prompt you to install them? Some other choice? – Didier Mar 26 at 9:27
  • @Didier Everything set to be as automatic as possible. Updated question with a screenshot. – Janus Bahs Jacquet Mar 26 at 9:29
  • OK, so UNCHECK all the boxes in the Advanced window, reboot your machine, go back to Software Update, check all the boxes again, reboot again, and you'll see that either the update badge is gone (no updates pending) or that updates are being downloaded and installed. AFAIK, you're running the latest stable version of macOS, but if you're subscribed to some Flight Test program, or if updates are available other than a newer version, they'll install then. – Didier Mar 26 at 9:37
  • @Didier Alas, what happened when I did that was option 3: absolutely no change. The badge is still there, but it still says I’m up to date. I’m not subscribed to any Flight Test or beta release programmes (that I know of). – Janus Bahs Jacquet Mar 26 at 9:50
  • OK, try this: Open Terminal (in Applications/Utilities, if you haven't already pinned it to your Dock...), type or copy-paste the following command: "softwareupdate -l" (no quotes, and that’s a lowercase “L” and not the number one) then press Enter. If updates are listed as available, type or copy-paste "sudo softwareupdate -i -a" (no quotes) and press Enter. This will automatically install all pending updates, should there be any. You'll need to enter your admin password at the prompt. If it's your first use of Terminal, don't freak out when the cursor doesn't move as you type. – Didier Mar 26 at 10:30
0

Check/uncheck automatic software updates in system preferences, then go to the advanced panel and just click OK. Worked for me.

New contributor
Rinne is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • That’s what appears to have done the trick for me as well – hasn’t come back yet, and it’s been six hours now, so fingers crossed. – Janus Bahs Jacquet Mar 26 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.