0

Just when I thought I had a complete understanding of how SSH works and what not, its randomly stops working again out of the blue again. My permissions are perfect on both machines. One is a Debian machine and the other is a windows machine using WSL

.ssh = 700 (drwx------)
id_rsa.pub = 644 (-rw-r--r--)
id_rsa (private) = 600 (-rw-------)
authorized_keys = 600 (-rw-------)

On both machines I uncommented and set it to PasswordAuthentication and set it to no And I uncommented PubkeyAuthentication and set it to yes

I restarted ssh on both computers to make sure the settings are up to date. I even used debug level 3 to see what's going on. I have gave both computers their respective public keys and have them in the authorized_keys file, but I'm still confused...

OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017
debug2: resolving "deb99" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to deb99 [192.168.1.185] port 22.
debug1: Connection established.
debug1: identity file /home/ghost/.ssh/id_rsa type 0
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/ghost/.ssh/id_ed25519-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.9p1 Debian-10+deb10u2
debug1: match: OpenSSH_7.9p1 Debian-10+deb10u2 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to deb99:22 as 'izuhu'
debug3: hostkeys_foreach: reading file "/home/ghost/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/ghost/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from deb99
debug3: order_hostkeyalgs: prefer hostkeyalgs: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: rsa-sha2-512,rsa-sha2-256,ssh-rsa,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:hhqp/XWY6px3iVwD6X6+Zm8URnnS+Jbh+XUIrFFgzBc
debug3: hostkeys_foreach: reading file "/home/ghost/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/ghost/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from deb99
debug3: hostkeys_foreach: reading file "/home/ghost/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/ghost/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from 192.168.1.185
debug1: Host 'deb99' is known and matches the ECDSA host key.
debug1: Found key in /home/ghost/.ssh/known_hosts:1
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug2: key: /home/ghost/.ssh/id_rsa (0x7fffe2daf180)
debug2: key: /home/ghost/.ssh/id_dsa ((nil))
debug2: key: /home/ghost/.ssh/id_ecdsa ((nil))
debug2: key: /home/ghost/.ssh/id_ed25519 ((nil))
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: RSA SHA256:VSUBaSXtJL5FS4ljSDbvAOpCrfFyHKnujJZ4rXdtnMU /home/ghost/.ssh/id_rsa
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug1: Trying private key: /home/ghost/.ssh/id_dsa
debug3: no such identity: /home/ghost/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/ghost/.ssh/id_ecdsa
debug3: no such identity: /home/ghost/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/ghost/.ssh/id_ed25519
debug3: no such identity: /home/ghost/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
izuhu@deb99: Permission denied (publickey).

What exactly is the problem ? Also, I'm not sure if my debug is showing anything that's only met for my eyes so I reset my ssh key again haha

New contributor
PrimRock is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1

Packet type 51 means "SSH_MSG_USERAUTH_FAILURE", and it typically occurs when the server doesn't recognize (or like/support) the public key the client presented.

In such cases troubleshooting is best accomplished by enabling debug logging on the server side, and looking at the server's debug log output to determine why it's rejecting the public key.

Common problems include:

  • .pub file (or corresponding key) hasn't been properly configured on the SSH server for the user account you're attempting to authenticate.

  • .pub file (or corresponding key) is there on the server, but the file in which it resides has permissions which are too open and you'll need to fix permissions on that server-side file before the server will allow it to be tried for authentication.

You provided information on permissions, but it's not clear if the permissions you show are of the .ssh directory on the SSH client's machine or the .ssh folder on the SSH server's machine (i.e. the .ssh folder in the izuhu user account's home folder).

Best bet for next steps would be to check logging on the ssh server side to find out why it's rejecting the public key.

|improve this answer|||||
New contributor
jdev is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • I realized I was using sudo on one machine and not the other...It resulted in looking for a key that wasn't really there....The root key...fml... – PrimRock Mar 27 at 10:07
0

If all your permissions are correct on both machines, you've restarted ssh through the changes, you made sure the machines are given each their respective keys, etc and it STILL fails

PLEASE

make sure you aren't running ssh with sudo on one computer and not the other. When you do this two different keys will be used. One for the root and one for the regular user. You see in my case....ssh was looking for a root key when I haven't even generated one which is why it kept throwing the SSH Permission denied (publickey) error.

I got upset by how much time I wasted on this and unnecessarily wiped Debian box completely out of frustration. I assume that this is what I was doing on my old Debian setup, because I was still struggling trying to get ssh to work on a fresh install. I really didn't spot the problem till I debugged the other machine like jdev consulted...

I hope this truly does help someone, because I wasted WAY TOO MUCH TIME than I'm proud of saying. My lesson through all this....

If a verbose or a debug mode is available in anything you're having trouble with....

USE IT TO THE FULLEST EXTENT! DON'T BE STUBBORN!!

|improve this answer|||||
New contributor
PrimRock is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

PrimRock is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.