1

OS: Windows 10

Model of my mouse: A4Tech OP-620D


For the past few days I'm facing the following stated problem with my mouse.

When I turn on my desktop, the mouse pointer doesn't appear. But the LED of my optical mouse is lit on. And inside Device Manager it is shows that the device is working properly. The interesting thing is after a while, the cursor itself appears and starts responding to the inputs.

I've tried several things to see what works to solve the issue. Such as,

  • Disconnecting and then reconnecting the mouse.
  • Reinstalling the driver.
  • Changing the USB port.

But till now nothing had worked for me. I've checked another optical mouse which worked perfectly. I've searched the internet but couldn't find any discussion related to my issue. My mouse is an old one and I'm now thinking to replace it. But it would be helpful if anyone can shed some lights into the matter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.