2

I want to keep my Windows 10 laptop running even "when I close the lid". I understand there's an option in the "Power Options" where you can select "Do nothing" at "When I close the lid". But the laptop still goes to sleep after some minutes even when I have it plugged in. And I have not external monitor attached to it. I simply want to remote desktop to it all the time. Is this possible?

enter image description here

3
  • Did you set it to never sleep?
    – jw_
    Mar 28, 2020 at 6:08
  • @jw_ yes it is "never" sleep.
    – Niner
    Mar 28, 2020 at 19:50
  • A possible ugly workaround is try to always press some key like put something on an external keyboard. If you have some fruit pie like arduino you can let it work as HID devices to constantly send commands to PC.
    – jw_
    Mar 29, 2020 at 2:09

2 Answers 2

0

There is more than one setting to adjust. The one you adjusted basically stops the closing of the lid as a trigger.

The other setting has to do with inactivity of the user. It's for energy conservation, to shut it down when not in use, or security, to prevent access if you are away for a while.

In 'Power Options' change 'Change When the Computer Sleeps' to 'Never'

6
  • that is already what i did in my original question above. 'sleep' is 'never' for my settings. as far as "inactivity" as you mentioned, it does not seem to matter. i made the laptop running all night last night with the lid not closing, and it never went to sleep. it only sleeps when the lid is closed even w/ the settings set to 'do nothing' and 'never'.
    – Niner
    Mar 28, 2020 at 19:49
  • I see it now, in the comments of your question, thanks for drawing my attention to it. My answer is irrelevant of course and just ignore it. I also see that it was added only a minute ago
    – Ack
    Mar 28, 2020 at 19:52
  • Did you do that for when it's plugged in as well as for when it's on battery?
    – Ack
    Mar 28, 2020 at 19:54
  • yes. please see my screen-shot above
    – Niner
    Mar 28, 2020 at 20:26
  • ok, I see the new screenshot that you added. A quick search online noted someone that was having the same issue and was able to solve the issue with a BIOS update
    – Ack
    Mar 28, 2020 at 20:30
0

First go in to Control Panel then Power Option. From there select "Choose what the power buttons do". Then select When I Close the Lid "Do Nothing". That will fix your specific request. While you are there check out the other options.

2
  • that is already what i did in my original question above.
    – Niner
    Mar 28, 2020 at 19:49
  • Is it going to sleep or is the screen just blanking. Screen blanking would bit be included in the "Do Nothing".
    – Ziggy32
    Mar 29, 2020 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.