0

"There were problems installing some updates, but we'll try again later. ..... Error 0x80070057"

That error code is so generic, it didn't get me to a solution. I spent a couple of days on this and solved it eventually and will provide the solution I found later in case it helps anyone else.

What I tried were the following steps:

  1. Created a system restore point for later recovery if needed.

  2. System disk checked: Your drive was successfully scanned. Windows successfully scanned the drive. No errors were found.

  3. Based on https://support.microsoft.com/en-hk/help/4027322/windows-update-troubleshooter - Ran the troubleshooter: "Troubleshooting couldn't identify the problem."

  4. Attempted to Install Diagnostic Data Viewer; "Error" Clicked 'See details' "Something unexpected happened Reporting this problem will help us understand it better. You can wait for a while and try again or restart your device. That may help. Code: 0x80070057" [Yep, the very one I'm trying to fix.]

  5. Working from https://support.microsoft.com/en-us/help/4089834/windows-10-troubleshoot-problems-updating?ocid=20SMC10164Windows10

    • My C: drive has 296GB free

    • Restarting hasn't helped. I've had this problem for days and the PC has been restarted multiple times.

    • Retried checking for Updates in Settings: Same errors.

    • Removed non-essential devices, tried Windows Update again: Same error reports as listed above.

    • Updated drivers, retried checking for Updates in Settings: Same errors.

    • Device Manager shows no yellow triangles/exclamation marks

In cmd as admin, did:

net stop bits

The Background Intelligent Transfer Service service is stopping..

The Background Intelligent Transfer Service service was stopped successfully.

ren %systemroot%\softwaredistribution softwaredistribution.bak2

ren %systemroot%\system32\catroot2 catroot2.bak2

Access is denied.

[Took ownership of catroot2, added my user, gave my user Full control - this is probably not recommended, and didn't work anyway]

ren %systemroot%\system32\catroot2 catroot2.bak2

The process cannot access the file because it is being used by another process.

[Tried to unlock it with IOBit Unlocker: BSOD, restarted in Safe Mode, renamed catroot2 as catroot2.bak, restarted normally]

In cmd as admin, did:

net start bits

The requested service has already been started. More help is available by typing NET HELPMSG 2182.

net start wuauserv

The requested service has already been started. More help is available by typing NET HELPMSG 2182.

Restarted machine

Tried Windows update: it gave the above 3 error messages as before.

Uninstalled Avast Free Antivirus.

Tried Windows update: As before, but I saw that while trying it did download and install an update to Windows Defender.

Reinstalled Avast.

Tried Windows update: Error as before.

Performed a clean boot in accordance with https://support.microsoft.com/en-us/help/929135/how-to-perform-a-clean-boot-in-windows

This involves stopping all non-MS services and all startup software

Windows update worked.

Restored from the system restore point. Everything except Windows Update working again.

Now I have to find out which startup item or service is causing the problem. There are many, but at least I have a path to a solution.

0

After trying various startup and service items, I eventually found that the problem was the Cybereason RansomFree service. This app has not been supported since January 2019, but I carried on using it.

After uninstalling it, Windows Update works on both of my Win 10 PCs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.