0

I'm trying to run Windows 10 using VirtualBox on a Debian 9 machine. When trying to set up the VM, I couldn't choose the 64-bit version of Windows 10 in the menu, so I downloaded the 32-bit ISO instead. When trying to start the VM, I get the following error message:

Error code

What's the problem? Are there any good (and free) alternatives to VirtualBox that could do the job? I need to do this on a workplace machine on which I can do sudo, but have no root permissions (and this will most likely not change in the future).

UPDATE: I followed the instructions here to check if VT-x is enabled and it seems to be disabled (the register returns 1 instead of 5), but unfortunately I cannot do anything about this at the moment. However, after following Ramhound's links and the advice here to reduce the allocated RAM to below 3 GB, I got this prompt:

Prompt

I'm neither using OS/2 nor QNX - so when I click Continue, the VM actually seems to start and I even get the proper Windows startup screen:

Windows screen

It didn't progress from here until I finally switched off PAE/NX, and now I'm getting this Windows 10 bluescreen:

Error code 0xc0000260

Which is kind of strange, because the CPU (Intel Core i5-6500) supports PAE, so it should not be necessary (or even counter-productive) to disable PAE/NX, right?

Imho the VM is already up and running and it's just some VirtualBox setting(s) causing the hiccup. I feel like being this close to the solution... Here is the complete VirtualBox logfile, maybe this contains some clues?

UPDATE: As Didier suggested, I also tried a ready-made Windows 10 VM as explained here. After downloading the VM from the Microsoft Dev Center and fixing a minor error/incompatibility (in 2020, absolutely nothing seems to work out of the box anymore), I tried to start the VM. Result:

Startup screen Bluescreen

5
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – DavidPostill
    Apr 1, 2020 at 15:27
  • @Didier: Ok, many thanks!! Will try the ready-made VMs, maybe I can even activate them using my license key...
    – david
    Apr 1, 2020 at 15:30
  • A tremendous alternative to Virtual Box is VMware Workstation. It will install and run both 32-bit operating systems and 64-bit operating systems. VT-x needs to be enabled for 64-bit guests, but your 32-bit guest should install and run just fine.
    – John
    Apr 1, 2020 at 15:38
  • Yes, I actually used to work with VMware Fusion on a Mac (great program!), but they only have commercial licenses afaik. By the way, I actually need to run the 64-bit version, the main only reason went with 32-bit is because VirtualBox didn't give me another choice
    – david
    Apr 1, 2020 at 18:23
  • @david - You will still need VT-x enabled in order to run a 64-bit operating system within a VM, this will be the case, for any hypervisor that exists. So contact your Administrator in order to enabled it for you.
    – Ramhound
    Apr 1, 2020 at 19:46

2 Answers 2

0

There are several possible causes for the error, see this.

As per your description, check in your BIOS if VT-x is available and enabled.

See also this. Check if it is a RAM related issue (allocate less than 3Gb). Check if turning PAE/NX on/off works (Virtual Box "Settings" > System Settings > Processor > Enable the PAE/NX option). Check if also enabling VT-d at the BIOS level works.

7
  • Unfortunately, I don't have permissions to access BIOS
    – david
    Apr 1, 2020 at 12:12
  • @david - Then, your options are checking if conditions suggest the other possible points of actions are relevant, or trying them directly. Please remember posting feedback! Apr 1, 2020 at 13:58
  • Yes, I did (sorry, if that wasn't clear) and appended this to the question. It seems we're edging towards the solution, but it's not quite working yet
    – david
    Apr 1, 2020 at 14:05
  • @david - Ok, it seems (perhaps) PAE/NX brought you closer to the solution. Good. Apr 1, 2020 at 14:46
  • At first glance, yes! But paradoxically, the CPU does support PAE, so this option should be enabled...
    – david
    Apr 1, 2020 at 14:52
-1

0x80004005 error may happen in the middle of Windows Update process which stops the update immediately. If this is the case, run the Windows Update troubleshooter to fix the issue. Here’s how.

Go to Start Menu. Search for Settings and open it. Click on Update and & Security.0x80004005 Error Code Windows From the left panel, click on Troubleshoot. Select Windows Update. Then click on Run the troubleshooter.0x80004005 error windows update The troubleshooter will now automatically find and fix any problem that stops your computer from downloading and installing Windows updates.

If running troubleshooter doesn’t help fix the problem, it may indicate that there are corrupted system files that causes the unspecified error 0x80004005. Try running SFC scan to automatically finds and repair system file in Windows 10.

To run SFC, go to Start Menu. Type CMD to search for command prompt. Right click the command prompt from the result, and click on Run as administrator. In the command prompt, type the following command.

/sfc scannow system file check sfc scannow

It will now begin to scan and repair any corrupted system file found. It may take some time. After the scan is completed, try to run the Windows Update again.

3
  • Sorry, but I'm not sure if the VirtualBox error code 0x80004005 is in any way related to the Microsoft error code 0x80004005 to which your answer seems to be related to - or is it? Currently, I cannot even start Windows let alone run Windows Update. I'm trying to run the VM on a Debian 9 machine
    – david
    Apr 1, 2020 at 12:17
  • @david - This answer isn't relevant to your problem, the author of this answer, failed to identify the problem you actually have.
    – Ramhound
    Apr 1, 2020 at 14:28
  • I know, but that's fine
    – david
    Apr 1, 2020 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .