1

Currently I am using Xcode 10.1 on MacOS High Sierra 10.13.6, on MacBook early 2011 with 4GB ram.

Problem is that I am unable to upgrade my MacOS Version to Catalina, Is it possible to install xCode11.3 in same macOS High Sierra? or any other safe solution for installation of MacOS Catalina in my unsupported MacBook pro early2011 and then to install xCode 11.3?

Please suggest a well tested and safe solution.

3
  • Short answer: No. Xcode 11.3 requires a Mac running macOS Mojave 10.14. 4 or later. – DavidPostill Apr 1 '20 at 14:49
  • @DavidPostill Thanks for your comment, I already aware about the fact that MacBook Early 2011 is not capable of doing that officially it is unsupported, But my problem is that I am in the area which is locked down currently & I needs to install Xcode11.x on this Mac Machine for at least one month even it is officially unsupported but I needs to work in swift 5. – Faiz Fareed Apr 1 '20 at 15:08
  • It's not possible. – DavidPostill Apr 1 '20 at 15:08
0

If you require Swift 5 then you can get away with XCODE 10.2.

You can get 10.2.1 by following https://codewithchris.com/xcode-update/.

I just wanted Swift 5 since I am learning to program in it. Will get a new laptop later.

I have Xcode 10.2.1 running on OS 10.13.6. This means I have Swift 5.0.1. The latest Swift 5.2 requires Xcode 11.4.

0

I've downloaded Mac OS Catalina latest version patcher from http://dosdude1.com/catalina/ and installed according their instructions. After that I've simply used MC OS Catalina Appstore app to install latest version of Xcode, it installed everything which i required, but the meantime speed goes too slow... but it works for me untill I purchase a new laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.