0

I have an industrial Windows XP machine physically wired to a large multi-city network that I'm trying to keep alive. The device has an application that sends packets on port 80 to a server when a user initiates the send. The packets are probably a megabyte to 10 megabytes. The packets themselves are a mystery to me and are proprietary to the manufacturer of this device. Overall, however, they are binary blocks of proprietary information that represents a lot of data.

Over the past two months, this device aperiodically does not send the packets and the application produces an error that the files could not be sent. When I run a constant ping to the destination, sometimes when I try to send a file, the ping immediately drops to "Request timed out." and the file send fails in the application. The issue appears to be more prevalent when I send more information. The issue occurs approximately every 3 times I send.

If I unplug the network cable and immediately plug it back in (we're talking a quarter of a second out of the jack), the ping comes right back to life as if the connection were never lost. If I lose the ping, I can also regain it by going to Network Connections and Disabling the network adapter and then re-enabling it. Without strong data, I feel that the issue repeats more often if I disable and re-enable the NIC than when I physically unplug the cable.

When the device cannot ping the server, it also cannot ping anything else anywhere. It's like it's cut off from the network.

I have an identical device in the next room that sits on the same network and I'm not able to replicate the problem, though staff tells me it sometimes "acts up" the same way. But again, I've not been able to reproduce the problem.

My main question is: What could cause a device to lose network connectivity, but have it restored by disconnecting and then immediately reconnecting the network cable (a CAT5)?

Some other causes I have ruled out: CAT5 cable (tests good, replaced) Network congestion (problem occurs during high and low use, no major issues seen in congestion) Server issues (it's sending to many devices without issue) Switch (tried connecting to new switch and new port in the closet) Cable in the wall (tests fine) Wall Jack (tests fine)

My thoughts are: Perhaps a NIC card going bad? Perhaps a software anomaly?

1

Unplugging a cable (dropping link) resets a lot of state in the NIC hardware, its driver, and the network stack. So it could be a bug in any of those that's causing it to get into a bad state.

Figuring out how to avoid this problem could require low-level debugging that only a network engineer or a driver engineer could enjoy.

If you think this is something that only happens after a lot of use and never happens right away after a reset, you might be best off writing a script that periodically disables and re-enables the interface, so that you're always resetting it before it can build up to the problem state.

| improve this answer | |
  • 1
    I'd also be tempted to drop 20 bucks on a new NIC [something high rep like an Intel]. Cheap enough to experiment with. – Tetsujin Apr 2 at 7:44
  • A simple wifi dongle and some changes to configurations was the answer to my problem. – Tallima Apr 13 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.