1

bios and cpu-z both say 16gb of ram installed windows and task manager both say 12gb installed and control panel has only 60mb reserved and also ram slot 3 and 4 dont work i have to go to asus bios and disable DRAMM b slot 1 and put the stick to slot 1 for some reason, if i have all ram spots enabled then the pc wont boot with 3rd ram stick in 3rd of 4th spot. I have 4x2 4gb sticks and 1 8gb stick all hyperx fury sticks, my motherboard is asus pro b250

2
  • 1
    You have an integrated GPU in your CPU right? Some of the system ram gets set aside for that GPU to use as video ram. You should be able to reduce how much in the bios. Apr 1, 2020 at 21:13
  • 1
    Do all your sticks share the exact same characteristics in terms of clock speed? Could be one is slower and is being ignored by your mobo because it can't underclock the whole bus. Can you set the RAM clock speed manually on this mobo?
    – user1019780
    Apr 1, 2020 at 22:07

2 Answers 2

0

Check your motherboard socket for bent pins.

For what you say SPD (the protocol used to tell which slot is populated, with the manufacturer and specs) is working fine, but the data lines are not. That is also why CPU-Z show all the capacity.

Most common cause for this are:

  1. Bent/damaged pins in the socket
  2. Bad memory controller on the CPU (sometimes only one of the 2 channels fails)
  3. Broken or badly plugged memory stick (we can discard this in your case, since you swapped them)

First two possibilities would also explain the other problem you had. It is not likely to be a case of the integrated GPU using the memory as one comment stated, since it would show as "system reserved" in the control panel aswell, and 4GB of lost RAM is far greater than the values that are common in these cases.

0

Both BIOS and CPU-Z use SMBus to access the Presence Detect on the RAM modules, so they will "see" them almost no matter what.

This does not mean that the motherboard MMU can or wants to use them. I do not know what kind of channel organisation your motherboard has, but try placing the three sticks this way:

slot 1: 4GB slot 2: 8GB slot 3: 4GB slot 4: empty (and possibly disabled)

If you put 4 GB in slots 1 and 2, and 8GB in slot 3, it might happen that only those lines on the 8GB stick that also are available on the 4GB stick will be used by the MMU, in order to best exploit dual-channel access strategy. In other words, the motherboard will privilege speed over capacity, and give you 4+4+4 = 12 GB of RAM.

Using a 4-8-4-0 configuration, you should have 8GB of fast RAM and 8GB of slightly slower RAM. Or you might have 16GB of slightly slower RAM, all timings in accordance to the lowest common denominator access method available. I'm betting on the first, because this is what you already should be having - (4+(8/2))GB of fast RAM and one 4GB stick accessed more slowly.

(But, of course, it might also happen that no RAM is seen at all).

There might be some configuration option in the BIOS on how to optimize memory, but if you have one of those newfangled super-duper gamer mobos, then chances are that it has a mind of its own, and will only do autoconfigure after testing the slots.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .