I first noticed that fsck_hfs was running, taking up 50-75% of a CPU, yesterday. It continues to run today.

Running ps -ax shows that it is doing /sbin/fsck_hfs -f -n -x -E /dev/disk3. Only problem: I don’t think I have a /dev/disk3.

  1. Why is it running?
  2. Will it ever finish?
  • Can I kill it?
  1. What is /dev/disk3? Could it be my Time Machine volume, which is not mounted at the moment?

System Info: MacBook Pro (2008). It has two disks installed—the internal disk (/dev/disk1) and a PC Card SSD (/dev/disk0, surprisingly). It connects to a remote Time Machine volume attached to an Airport Extreme base station.

  • 2
    another datapoint; my 10.13.5 laptop just spent two hours "verifying" a backup on a NAS drive, apparently stuck at 84%. Majority of the CPU time was going to fsck_hfs (similar command line to the OP) with basically zero network traffic (~5 packets per second) and I think disk IO Ops/s were low as well but I wasn't checking that as much. No apparent change in progress was reported in the GUI (that I noticed) and then it just completed successfully.
    – Sam Mason
    Jul 3, 2018 at 16:47

4 Answers 4

  1. It was probably running from when your Time Machine volume was mounted.
  2. If the volume isn't present anymore, I doubt it.
    • I'm sure you can sudo killall fsck_hfs; it wouldn't hurt anything. (Have you tried restarting?)
  3. It probably is.
  • Thanks for the help! You were right. Moments after killing it, Time Machine popped up saying it was unable to verify my backup. It probably became confused last night when I closed my MacBook and took it home. Crazy that it will try to verify a ~750 GB disk image over Wi-Fi! I would have to leave my computer turned on and at the office for several days for it to complete…
    – Nate
    Jun 17, 2010 at 19:30
  • 1
    You probably don't want to force quit it because it forces you to rebackup your entire computer and you then loose the existing back up history
    – Allison
    Sep 1, 2015 at 2:19
  • 1
    @Nate "… it will try to verify a ~750 GB disk image over Wi-Fi! …" – that's not what happens; only a fraction of the image is transmitted. Keyword: CopyHFSMeta, please see for example forums.freenas.org/index.php?threads/… Jan 30, 2016 at 12:04
  • Thank you so much. I have been for days trying to figure out how to format my USB pendrive.
    – Leo Dabus
    Mar 6, 2021 at 8:07

Clicking on the Time Machine icon in the menu bar and choose "Skip verification" caused the fsck_hfs process to stop itself. Maybe a bit nicer than kill...

  • Just let it run, just wait for it finish.
    – Zhang Buzz
    Jun 29, 2019 at 2:00

You can also click on the Time Machine icon, select "Open Time Machine Preferences...", and you should see a progress bar for how far along the "Backing Up" process is.

You can then click the "x" next to the progress bar to stop the verification process.


I would recommend against killing it.

Last time I did, it left my Time Machine backup in a state where OSX believed it to be corrupted. This resulted in OSX refusing to continue using this backup, i.e. OSX queried me to create a new backup (which would effectively mean I would loose any history in my backup, e.g. deleted files, previous versions of modified files, etc.)

I managed to bring the Time Machine backup into a good state, allowing OSX to continue using this backup, but it was quite a hassle.

  • Care to explain your process getting the backup back into a good state? I have an empty sparsebundle on my Time Machine now.
    – Matt M.
    Apr 28, 2017 at 4:37
  • @MattM. If your sparsebundle is truly empty, I don't think you can save it. But if it's not empty, just marked as corrupt as mine was, it should be salvageable. I can't remember exactly what I did, found the solution through a google search. But the sparsebundle contains some metadata file that has a property telling that the backup is being checked/corrupt. So the process was something like unmount the time machine volume, find the metadata file, adjust those properties, and possibly remount the time machine volume (maybe I manually ran a verification step afterwards)
    – Pete
    Apr 28, 2017 at 10:24
  • I used Data Rescue 4 for Mac, and it worked like a champ for $99. I didn't want to risk any irreversible loss by editing the metadata. It restored the data directly onto my local drive, reading the sparsebundle from Time Capsule connected over ethernet.
    – Matt M.
    May 2, 2017 at 8:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .