0

We have the reverse problem to the OP in this question (Mac Dual Monitor: Prevent Second monitor to go black while first one is fullscreen). He is asking how to prevent black out of the primary display when there is a fullscreen app on the secondary display. Wish we had this problem...

We want the primary display to be blacked out when playing (VLC) full-screen on the secondary screen. (The primary screen is the iMac itself, the secondary screen is a MiniDisplayPort to HDMI connected projector.)

What we tried: 1. F2 to lower brightness – works somewhat, but only to low brightness not to blackout. 2 "Display have separate Spaces" enabled or disabled – does not work; in both cases, the primary screen does not go to black. 3. The shortcut Shift-Control-Esc – does not work, sets the secondary display (or both) to black (not the primary display even the active window and the mouse is on the primary display) 4. "Hot Corners: Put display to Sleep" – does not work, blacks out both screens.

How can we black out only the main (internal, primary) screen?

At the moment, I am putting VLC in separate space and have set a black desktop background, but there must be a better solution...

Cheers!

0

VLC Prefs > video > Black screens in fullscreen mode

enter image description here

This may require you to also change your Mission Control Spaces behaviour.
You may need to uncheck this. Mine works with this unchecked. I cannot test if it works checked as it badly messes up my workflow to change it.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.