This is my current 50-unattended-upgrades file:

Unattended-Upgrade::Automatic-Reboot "false";
Unattended-Upgrade::Allowed-Origins {

// List of packages to not update (regexp are supported)
Unattended-Upgrade::Package-Blacklist {};
Unattended-Upgrade::DevRelease "false";
Unattended-Upgrade::Remove-Unused-Kernel-Packages "true";
Unattended-Upgrade::Remove-Unused-Dependencies "true";

A containerd upgrade was done early in the morning

2020-04-03 06:39:18,853 INFO Initial blacklisted packages:
2020-04-03 06:39:18,854 INFO Initial whitelisted packages:
2020-04-03 06:39:18,854 INFO Starting unattended upgrades script
2020-04-03 06:39:18,854 INFO Allowed origins are: o=Ubuntu,a=bionic, o=Ubuntu,a=bionic-security, o=UbuntuESM,a=bionic, o=Ubuntu,a=bionic-updates
2020-04-03 06:39:22,458 INFO Packages that will be upgraded: containerd
2020-04-03 06:39:22,458 INFO Writing dpkg log to /var/log/unattended-upgrades/unattended-upgrades-dpkg.log
2020-04-03 06:39:29,941 INFO All upgrades installed

Which caused docker to stop via Systemd.

Apr 03 06:39:23 ip-10-2-1-12 systemd[1]: Stopping Docker Application Container Engine...
Apr 03 06:39:23 ip-10-2-1-12 dockerd[3214]: time="2020-04-03T06:39:23.782508859Z" level=info msg="Processing signal 'terminated'"
Apr 03 06:39:23 ip-10-2-1-12 dockerd[3214]: time="2020-04-03T06:39:23.933398454Z" level=info msg="ignoring event" module=libcontainerd namespace=moby
topic=/tasks/delete type="*events.TaskDelete"
Apr 03 06:39:23 ip-10-2-1-12 dockerd[3214]: time="2020-04-03T06:39:23.945486871Z" level=info msg="ignoring event" module=libcontainerd namespace=moby
topic=/tasks/delete type="*events.TaskDelete"
Apr 03 06:39:24 ip-10-2-1-12 dockerd[3214]: time="2020-04-03T06:39:24.155022784Z" level=info msg="stopping event stream following graceful shutdown" e
rror="<nil>" module=libcontainerd namespace=moby
Apr 03 06:39:24 ip-10-2-1-12 systemd[1]: Stopped Docker Application Container Engine.

Is there any way to override this behavior? I would prefer a systemctl restart rather than a systemctl stop.

Relevant data:

  • Ubuntu 18.04.4 LTS
  • Docker 19.03.6 installed by apt
  • This should not happen as far as I know. There was a similar bug here that was fixed in a previous version: bugs.launchpad.net/ubuntu/+source/docker.io/+bug/1658691 — my systems with 18.04.4 and Docker 19.03.6 (installed via unattended upgrades) never required a manual Docker start.
    – slhck
    Apr 3, 2020 at 14:36
  • Is your Docker installation configured to automatically start? docs.docker.com/install/linux/linux-postinstall/…
    – slhck
    Apr 3, 2020 at 14:39
  • @slhck, yes. The systemd unit is enabled. Actually, docker brings up automatically if I reboot the machine. Seems like unattended-upgrades is sending a stop signal to systemd.
    – Nico
    Apr 3, 2020 at 14:52
  • Did you ever figure this out? I just observed the same issue (Docker daemon not starting after an apt update), but only on one system, not the other…
    – slhck
    Apr 30, 2020 at 8:51
  • hi @slhck, no. For now I just disabled the automatic upgrades.
    – Nico
    Apr 30, 2020 at 15:48


You must log in to answer this question.

Browse other questions tagged .