5

I have the following network setup:

               .----.
   .---------. | == |
   |.-"""""-.| |----|             |   |
   ||       || | == |         \  _|___|_  /          _______
   ||       || |----|          \:       :/          :       :
   |'-.....-'| |::::|=== Eth ===:_______:=== Eth ===:       :-- Fiber --
   `"")---(""` |___.|                               :_______:
  /:::::::::::\" _  "            tp-link            
 /:::=======:::\`\`\            Archer C6          Fiber optic
 `"""""""""""""`  '-'                                 modem
     Desktop           Cable 1             Cable 2

What I've recently found interesting is that PC shows down/up speed of 255.56/264.11 (Mbps; link). This is way lower than the incoming (>1Gbps) and network cards/router physical limitations (both 1Gbps).

I tried connecting cable 2 directly to the PC - and it's surprisingly 363.86/907.48 (Mbps; link)!
900+Mbps looks somewhat close to what I've expected... But why doesn't it work with Archer C6 in the middle, which claims to be a Gigabit router? I've already tried replacing Cable 1 with other cables, but the result is still the same.

So 2 questions here:

  1. The bottleneck looks to be the router, right? Or am I missing something else?
  2. What could be next debugging steps? Or it's pretty much "contact support" now?

ps: just in case:

  • Router has the latest firmware
  • Desktop is quite old Win 10 with an old Realtek network card (PCI\VEN_10EC&DEV_8168)
  • Latest network drivers installed
1
  • 2
    While I cannot agree with your choice of hardware, I appreciate the effort it takes to write a question this well without any edits, and an ascii art diagram to boot. upvoted.
    – memtha
    Apr 3 '20 at 21:38
2

Yes, it's the router.

That said, contacting support will probably accomplish next to nothing. I am not familiar with that specific router, but go through the settings to see if it has any throttling settings built-in and turned on (including energy-saver, QoS, duplex mode etc.). Also verify nothing else is using up bandwidth (a wifi router that's worth its weight in salt should list connected devices). Otherwise you're probably stuck with replace it or live with it. I cannot recommend TP-link for anything.

Edit: While switching cables couldn't hurt, it's unlikely to have a noticible impact unless one is faulty, old (cat4) or really long.

Edit 2: Also verify the modem is plugged into the uplink port (blue), not a downstream port (yellow).

Edit 3: If that doesn't work, I suggest you use it as an access point and get a real gigabit router without wifi. See "Access Point Mode" in the tp-link page you linked.

5
  • Ok, thanks, clear. Some 2 years ago when I just had 50Mbps this router was more than enough, but obviously not anymore... Regarding your suggestions - already did that and couldn't find anything that helps. Although router's CPU consumption is at 100% during speed tests - so there may be a setting that helps.... I'll still probably contact tp-link support for some settings adice, but mostly out of curiosity. Apr 4 '20 at 10:35
  • 1
    @FlasHfromRu "router's CPU consumption is at 100%" So that's the bottleneck. (I was ready to blame the backplane). In that case, you might have something to gain by reducing the per-packet cpu load or increasing packet size. I would simplify the router's firewall as much as possible, reduce logging, and increase MTU (packet size) in the PC's adapter settings; and expect maybe 5% gain. Their CS might have a suggestion to that effect too.
    – memtha
    Apr 5 '20 at 15:59
  • did factory reset - 500/800Mbps. Restored my configuration - back to where we've started. So it's definitely one of my settings. Binary search to the rescue... Apr 8 '20 at 20:56
  • 1
    So finally. Did factory reset and re-configured everything manually. Latest result: 312/876Mbps (link). A tol better! The only differences with my setup, I've noticed are: SPI firewall (disabled --> enabled), IGMP snooping (enabled --> disabled) and IGMP version (v3 --> v2). Apr 9 '20 at 10:14
  • Interesting. I would not have expected anything IGMP to cause CPU contention during tcp load. I don't want to think about how [explitive] their firmware must be to cause that. Stateful firewall, on the other hand, was on the top of my list.
    – memtha
    Apr 10 '20 at 12:22
-1

First ensure the specs of ur desktop's NIC- use software like HWinfo64/AIDA64. Get the ethernet chip# & google to see its specs. Update Motherboard BIOS, OS drivers - instead of using Windows best try with Ubuntu liveboot without installing.

Try using Cat 5e/6 ethernet cable. Maybe you can connect 2 Gigabit ethernet NIC capable pcs to the lan ports of the same archer c6 & run iperf or some benchmark to see the throughput betn LAN clients.

Next step is conn 1 gigabit ethernet client to archer c6, in that archer c6's WAN port connect another wire & connect it to the LAN port of another gigabit router.

now on the 2nd gigabit router, connect another wire & benchmark on a gigabit client.

PC1 --- [LAN]Archer c6 [WAN] ----[LAN] GigabitRouter [LAN] --- PC2

PS: Regarding cpu usage, factory reset & firmware updates are best, try turning off firewalls. And within "System Parameters" ensure NAT boost is enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.