0

I've set dian to have full control of D:\movies folder, subfolders and files, yet some directory inside D:\movies, such as D:\movies\Game.of.Thrones.Season.6, have permissions for this folder only. [![Screenshot][1]][1]

Why is the permission for D:\movies\Game.of.Thrones.Season.6 this person only? What if I want dian to have permission for all folders, subfolders, and files in D:\movies, and not just that folder only? I cannot remove dian's permissions because I get this: Screenshot

What does it mean by I can't remove dian because this object is inheriting from its parents? Does it mean that the object is the folder and it's inheriting it from the parents' class?

What if I want dian to have full control of D:\movies and it's folders, subfolders and files?

3
  • 1
    Set permissions from the main folder "D:\Movies", you should be able to edit permissions for Dian from there.
    – vssher
    Apr 4, 2020 at 11:07
  • If I were you, I'd start from scratch: remove permissions on D:\Movies for all users except you, then add permissions one by one, for each user. Your problem is that you're trying to grant access to a folder in a directory (your D drive) that other users aren't allowed to access. It's kind of like telling one of your guests "hey, go grab a beer in the fridge" while leaving the kitchen door locked. That's what Windows means by "inheriting permissions". Also, you gunked out the folder owner's name. It's for confidentialy purposes, I understand that, but part of your solution could lay there...
    – user1019780
    Apr 4, 2020 at 11:42
  • 1
    To elaborate on @vssher's comment, the error box is telling you exactly what's wrong - you're trying to remove permissions on a subdirectory [D:\Movies] that's inheriting permissions from a parent directory [D:]. As @vssher mentioned, you can either modify permissions on the parent directory or add additional permissions for dian from ``D:\Movies` that would apply folders/files within D:\Movies.
    – JW0914
    Apr 4, 2020 at 12:30

1 Answer 1

0

I have figured out the problem

There is a checkbox.

"Apply these permissions to objects and/or containers within this container only"

That box is very unclear. Of course, the objects are only within this container. What does the box do?

It turns out if I check the box, it means what it means. Only objects within this container and NOT objects within the container within the container.

That is.

The permissions will only be 1 level deep if I check that boxes.

So uncheck it and problems are solved.

Another has that problem

https://serverfault.com/questions/424046/permissions-wont-cascade-more-than-1-level

1
  • Well it's good that you solved your issue! Yes, permissions in Windows sometimes work in mysterious ways, or, more like, Microsoft doesn't make things easy on the users. On the other hand, allowing one level down, to quote the other visitor's post, makes sense, because you could store individual files in that Movies folder, for everyone to read and/or write, and folders for specific users and them only. It's another way to proceed from some Unices, for example, where permissions go several levels deep as default if the OS has been set that way. With Microsoft, it's my way or the highway...
    – user1019780
    Apr 4, 2020 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .