10

Delete does not work, shift+delete does not work. It's frustrating to have old misspelled addresses constantly pop up and have no way to remove them. I constantly go to the wrong pages.

Windows 7.

2
  • Are the misspelled addresses genuine addresses (i.e. can resolve and be displayed, just not the website you want), or not?
    – Kdwk
    Sep 4 '20 at 4:11
  • Try to add the version of firefox you are using... maybe it changes the behavior. BTW if you click on the bar, select the url you want to delete and press the left shift and del it deletes the selected address. (Firefox 80 under Linux).
    – Hastur
    Sep 4 '20 at 18:28
2
  1. Click the "View history, saved bookmarks, and more" button (i.e., the button with an icon featuring books standing side by side).
  2. Click the "History" menu item in the menu that appears.
  3. Click the "Show All History" button at the bottom of the new menu that appears.
  4. In the "Library" window that appears, search for each relevant history item, right-click the history item, and select the "Delete Page" menu item in the shortcut menu.

Tested in Firefox 80.0 in Windows 10.

0

I have seen the delete function fail as well and came up with this solution:

  • Locate your browser profile folder (e.g. .mozilla/firefox/somerandomstring.default)
  • locate the file places.sqlite
  • Open it with a tool, that can handle SQlite V3 databases (e.g. the sqlite3 command line utility)
  • Use the SQL SELECT id, url FROM moz_places WHERE url LIKE '%xxxx%'; (with "xxxx" replaced by your typo) to locate the unwanted line and note the idcolumn (an integer)
  • Use the SQL DELETE FROM moz_places WHERE id=xxxx; (with xxxx replaced by the id value from above) to get rid of the line
1
0

Try the following:

  1. Press Ctrl+h to open the history pane.
  2. Set Search history to the web site name to delete (e.g., cnn.com).
  3. Press Tab twice to navigate out of the input field and onto the hyperlinks.
  4. Press Down then Up to select the first item.
  5. Press Shift+End to select all items.
  6. Press Del to delete them all.
  7. Press Ctrl+h to hide the history pane.

Then try it out:

  1. Press Ctrl+l to navigate to the location bar.
  2. Type: cnn.com

The website is vanquished.

0

It took me over an hour to figure out but it worked by doing this:

Go to Options-Home. In the 'Firefox Home Content' section, check Top Sites.

Open a new tab.

You should see a bunch icons below the search bar.

Hover over the site you don't want and click the 3 dots that appear . Click Dismiss.

The site should now be gone from the address bar.

EDIT: They've removed Top Sites and replaced it with a Shortcuts checkbox.

-1

Based on my understanding you don't want to auto fill the search bar and don't want to delete the history. so my recommended solution is:

  • add (blank space) before you start typing something

Google ignore it. Firefox won't auto fill. but it shows some suggestions, you can select one by using up and down arrow keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.