52

In a recent update a new Share with Skype context menu item has appeared. How can this item be removed?

enter image description here

PS: There is some information here, but it's not complete: https://www.reddit.com/r/skype/comments/fkxbhw/q_context_menu_share_with_skype/

6 Answers 6

43

In case you are using the Skype App, removing the context menu item is trickier.

One way is to delete DllPath under

HKEY_CLASSES_ROOT\PackagedCom\Package\Microsoft.SkypeApp_15.61.100.0_x86__kzf8qxf38zg5c\Class\{776DBC8D-7347-478C-8D71-791E12EF49D8} 

However updates to the app will probably restore this. Adding the following REG_SZ key

"{776DBC8D-7347-478C-8D71-791E12EF49D8}"="Skype"

to

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Blocked]

is probably a good idea. Restart Windows to take effect.

Blocking Skype Explorer extension


6
  • 7
    Confirm adding the HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Blocked key (of type REG_SZ) works on Windows 10, build 18362.959. Restart is required.
    – AlainD
    Jul 17, 2020 at 11:09
  • 13
    After new updates kept reenabling it under different key names, I was beginning to get tired of removing it every time. Adding it to the Blocked list removed it permanently for me on Win10 version 2004. And, you don't need to restart the computer; simply restarting explorer.exe is enough. Jul 30, 2020 at 2:01
  • 2
    It doesn't seem to work on Win10 20H2 on skype 8.66.0.77
    – Odys
    Nov 20, 2020 at 18:37
  • I think the class ref changed to {F2CC526B-08C7-4E0E-BA62-74A53C4AB446}, but that does not work for me. (Perhaps I have to restart).
    – Ajasja
    Nov 21, 2020 at 0:52
  • @Ajasja I actually had 2 entries in my context menu. The above solution removed one for me. I tried your suggestion but allas, no luck even after a restart. I'm running Win 10 x64 20H2 after a clean install so no previous versions were present on this system.
    – Jakke
    Dec 16, 2020 at 2:27
32

Yet another update: Works in Windows 11 too.

Update: Works in Windows 10 version 21H1 too.

Original answer:
As of Windows 10 version 2004, you can do the following to remove the "Share with Skype" from the context menu:

  1. Run the following REG ADD command in an elevated cmd:

    REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Blocked" /v {776DBC8D-7347-478C-8D71-791E12EF49D8} /d Skype
    
  2. Restart the Explorer process through Task Manager to see the effect. You do not need to restart Windows.

* Based on the answer given by Ajasja. So all credits go to him. I merely created the REG command.

1
  • 2
    Worked on Windows 10 version 20H2. Use CMD, not powershell.
    – Gustavo
    Jan 21, 2021 at 12:23
23

On Windows 8 (and Windows 10?), RegEdit found the entry at HKEY_CLASSES_ROOT\*\shell\ShareWithSkype

Deleted that, and the item disappeared from the context menu immediately - no need to reboot / log out.

No need to mess with ShellExView 2.01 because Skype did not show up there anyway.

4
  • 2
    Hmm, I don't see that entry i.stack.imgur.com/Ept6f.png on windows 10.
    – Ajasja
    Jul 17, 2020 at 2:58
  • 2
    At some point between April and July, Microsoft changed the way this works. Also see the answer from @Ajasja if this does not work for you.
    – AlainD
    Jul 17, 2020 at 11:11
  • 2
    Instead of deleting it I left the "folder" ShareWithSkype, deleted the items inside except the (Default) and changed the permissions excluding the user account. When skype updates it raises a warning but it can be ignored (there's an Ignore button) and the context menu is clean after the update!
    – Recct
    Jan 26, 2021 at 9:13
  • I can confirm this works on Windows 10 too. I think it depends if you are running the Desktop app or the UWP app from the Windows Store. I was running the full desktop app. May 17, 2021 at 14:53
10

There are two main entries for "Share with Skype" in registry.

  • To disable one from Skype for Desktop use following .reg file:
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\ShareWithSkype]
"LegacyDisable"=""

Method above survives reinstall. It also survives install if .reg file is merged before installation, so hopefully will survive updates too.
Deleting Skype via Control Panel also wipes this tweak, so manual reinstall requires .reg file to be merged again after deletion/installation.

  • To disable another one from Skype for Windows 10 use following .reg file:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Blocked]
"{776DBC8D-7347-478C-8D71-791E12EF49D8}"="Skype"
1
  • THANK YOU SIR, top answer! I did have them both, first tried the other solutions mentioned above but I kept with 1 remaining...now they're both gone. You made my day :)
    – Jakke
    Dec 16, 2020 at 2:34
4

The location has changed to:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PackagedCom\Package\Microsoft.SkypeApp_15.61.87.0_x86__kzf8qxf38zg5c\Class\{776DBC8D-7347-478C-8D71-791E12EF49D8}

Manually delete the DllPath value in the Registry Editor. Note that as the application updates it may change so take note of the path and look for a similaur GUID.

3
  • Testing this out now
    – nights
    Aug 1, 2020 at 10:12
  • Worked immediately without logoff or reboot... however: it came back a week later with a different path after Skype auto-updated. (Now Microsoft.SkypeApp_15.63.76.0_x86__kzf8qxf38zg5c instead of Microsoft.SkypeApp_15.61.87.0_x86__kzf8qxf38zg5c.) Aug 10, 2020 at 8:21
  • @StackzOfZtuff I also had this behaviour. I understand it to appear with skype for business updates.. if they even update that anymore. Aug 10, 2020 at 11:18
3

Just a reminder, that uninstalling Skype will of course also fix the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.