17

I have created an azure virtual machine with the following specifications:

  • Ubuntu 18.04 LTS
  • F16s_v2 Standard (16 vCPU and 32 GiB RAM)
  • SSD unit

Since I need to connect via Remote Desktop, I followed this guide to install xfce and xrdp. Once finished, I connected to the server with Microsoft Remote Desktop but I noticed an excessive slowness in interactivity. I don't think the problem is my internet connection because:

  1. By connecting to other Azure Windows VM I don't have the same problem;
  2. I asked to a colleague to do a test from his home and he experienced the same problem;

What could be the problem?

4 Answers 4

7

I'm using xrdp w/ KDE and these compositor settings appear to have helped quite a bit:

scale method: crisp
rendering backend: OpenGL 2.0
Tearing prevention: Only when cheap
Keep window thumbnail: never
Allow options to block composting: yes

KDE compositor settings for xrdp headless vm

Edit: To update for clarity, these values are in KDE's settings manager under Desktop Effects -> Compositor. They are not client-specific. The example is modifying the server's desktop environment settings to "dumb them down" a little bit.

Since XRDP is delivering the server's desktop via RDP protocol to your client, if XRDP has less data to send it follows that the remote desktop should be more responsive.

There was a question about clients - As far as clients I was using at the time, I'm sure it was KRDC and windows RDP client. I can't recall modifying any default settings on the clients, other than in KRDC making the window full-screen and client native resolution (so I could make it a separate virtual desktop).

Also, there is another response about reducing / eliminating default encryption from the RDP stream should be very helpful in making the entire process less CPU-intensive from end to end, if that's something your environment will allow.

Hope this helps.

3
  • 2
    This made a massive difference for me. Thanks!
    – Chris
    Jan 25, 2021 at 14:22
  • what user interface is this? Are these settings in your client? Which client do you use?
    – Zuabi
    Jun 10 at 20:56
  • @Zuabi I have updated the answer to make it more clear Jun 27 at 21:32
9

I installed Ubuntu server XRDP. Went through Windows and terribly slowed down. I solved this problem. In the /etc/xrdp/xrdp.ini file, change crypt_level=high to crypt_level=None

3
  • Thank you so much! Massive difference from this. The other suggestions aren't as effective if you are already dealing with a high-end CPU.
    – Jire
    May 21, 2021 at 20:55
  • 1
    After disabling animations and following this suggestion, remote desktop is once again responsive. How many times do you need to encrypt your traffic anyway? I remote desktop over an SSH tunnel. May 24, 2021 at 22:57
  • This sounds like a really good idea, I wasn't aware the stream is being encrypted by default Jun 27 at 21:28
7

I disabled the compositor, as suggested here: https://github.com/neutrinolabs/xrdp/issues/501#issuecomment-262905321

Hello, I have experiment same problem with xfce and ubuntu 16.04. I have disable compositor in xfce windows settings. Now it's work fine.

It made a huge difference, now everything works fine.

2
  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    May 14, 2020 at 20:03
  • 4
    Update (sept 2020) the Compositor tab is located in Window Manager Tweaks settings.
    – titusjan
    Sep 21, 2020 at 16:16
2

If you are using the recent versions, you need to enable the RFX codec. Use the link below for more information. https://github.com/neutrinolabs/xrdp/discussions/2136

2
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 11 at 7:17
  • this answer worked for me, launch: Microsoft Remote Desktop, Show Options, Experience tab, LAN (10 MBps). note: by default is detect automatically and I assume it sets a lower speed
    – eugen
    Aug 8 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.