0

After switching my office PC to Windows 10, the Remote Desktop connection does not allow copying files using copy/paste anymore. Copying text to a remote machine works like a charm though.

Steps to reproduce:

  • Connect to remote machine via RDP
  • In the file explorer on the local machine, copy a file to clipboard (Ctrl-C)
  • In the file explorer on the remote machine, paste the file from clipboard (Ctrl-V)

Result: No reaction.

Expected result: The file is copied via the network to the target directory on the remote machine.

I used this guide to set everything up, and copying text works, but copying files doesn't: https://www.technipages.com/unable-to-copy-and-paste-to-remote-desktop-session

One thing I didn't understand in the guide though: In the RDP resources dialog, you can select directories on the local machine to be included in the connection, but how can I set up the directories on the remote machine? I suspect it's not via the RDP dialog but some system setting on the remote machine itself. For Windows 7 I never had to do this if I recall.

This used to work with Windows 7. I contacted my company's IT department but they say that they don't offer support for RDP. I have the suspicion that the problem is related to group policies, since we are fairly restrictive about Admin rights, network sharing, USB ports, etc. If it turns out to be a policy issue, it would help a lot to get some more details about the specific policy in question, so I might have a better argument with IT.

I hope this is not a duplicate, but I couldn't find a related question, as it seems to be shadowed by a lot of text copy/paste problems.

6
  • In the RDP connection window: Show Options > Local Resources - Local Devices and Resources > More... > Select the local partitions you want to have access to within the RDP connection.
    – JW0914
    Apr 9, 2020 at 11:11
  • @JW0914 Thanks, I already did that, see the link I posted. I don't understand how to set the access on the remote side though. Or if I have to.
    – Cerno
    Apr 9, 2020 at 11:19
  • I've never had this issue with accessing Windows 10 or Ubuntu in an RDP session from Windows 10 and there's no option I know of that needs to be enabled beyond that for this to work, which would seem to point towards a Group Policy or otherwise on the work PC that's preventing this (I'm not well-versed in Powershell, but there's likely a way to troubleshoot this with Powershell to know for sure).
    – JW0914
    Apr 9, 2020 at 11:40
  • Thanks for your input. I know next to nothing about group policies, so I'm hoping some experienced admin can shed some light on this.
    – Cerno
    Apr 9, 2020 at 12:03
  • @JW0914 Thanks for your input! This strenghtens my argument.
    – Cerno
    Apr 28, 2020 at 11:01

2 Answers 2

1

If text copies but files don't copy, it may indeed be group policy related. In addition to disabling the "Do not allow Clipboard redirection" policy, you also need to disable the "Do not allow drive redirection" policy for copying files to work.

Location of policies: Computer Configuration > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection

From the Help text on the "Do not allow drive redirection" policy:

If you enable this policy setting, client drive redirection is not allowed in Remote Desktop Services sessions, and Clipboard file copy redirection is not allowed on computers running Windows Server 2003, Windows 8, and Windows XP.
If you disable this policy setting, client drive redirection is always allowed. In addition, Clipboard file copy redirection is always allowed if Clipboard redirection is allowed.
If you do not configure this policy setting, client drive redirection and Clipboard file copy redirection are not specified at the Group Policy level.

Source for this lifesaving piece of info: https://social.technet.microsoft.com/Forums/en-US/c3cd1c38-0e07-438f-91ff-07558dd8c2c6/can-copypaste-text-but-not-file-via-remote-desktop-gateway-problem-only-on-windows-10?forum=winserverTS[1]

2
  • I know this is plastered all over the internet but Drive Redirection is NOT a requirement to cut and paste files. Not sure where this bogus information comes from. Maybe a legacy requirement? I have zero drive redirection turned on anywhere in my domain and the cutting and pasting of files works just fine (just not server 2022). None of my hosts show the clients drives in My Computer and none of them can access \\tsclient\ and yet cut and paste works fine. Sep 3, 2023 at 20:39
  • Can confirm that this does not work. Have enabled both clipboard redirection and drive redirection on both host and client machine and nothing changes: copy/pasting text works, copy/pasting files does not. Maybe some master policies override my local policies but in any case, it does not work unfortunately.
    – Cerno
    Oct 15, 2023 at 15:43
0

Found under Computer Policies > Administrative templates > system > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection > Do not Allow clipboard redirection

for instance gratification > either delete or change the registry key HKLM\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fDisableClip to 0

Where as Folder Redirection is a User configuration policy > found under windows settings > folder redirection. This policy has no effect on the ability to copy and paste files to an RDP session.

1
  • Thanks for your contribution! For the first part, could you specify where I can get to Computer Policies? I was not able to find it on the start menu search nor on the internet. For the second part, the key you mention was not set on either PC nor did adding it with value 0 change anything. Following the documentation I wouldn't have expected it to since as I described in the OP, copy/pasting text works, but copy/pasting files does not.
    – Cerno
    Oct 15, 2023 at 15:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .