1

I have a Linux server on a 192.168.x.y subnet talking to a few devices and a single Windows server. I am talking to the Windows server over it's 10.a.b.c subnet/vlan internal to the site I work at. In the linux box I have made /etc/ssh/sshd_config have X11Forwarding=yes set in place, sshd has been restarted, but I keep being unable to get Xming on the windows server to see the Linux desktop, I keep getting a black screen. At this point I am RDP'ing to the Windows box, and can WinSCP and putty connect as each of several user roles available, so can run commands on there. As it is a private network (the 192.168.x.y) part I do not need to care about security, It is an isolated 19" rack on wheels, used where required, the only way to break in is over the 10.a.b.c lan. I did briefly get x11vnc to run and could connect, but have forgotten to write down what worked.

The Linux server does have X11 running to serve up the GUI locally on its screen. Most of the time it is controlling some instruments, eg a spectrum analyser, but there is a GUI for calibration etc, I need to get that visible on the Windows server for the next few weeks/months.

I have set up Putty to do the ssh forwarding, but keep getting what seems to be permission issues.

Normally we just have local access to relevant keyboard and Mouse, but now I need to allow remote access so that the small team may do more from home. Company IT have set it up so that we may RDP to the Windows server, so half way there. It has now fallen to me to enable viewing the existing desktop in a VNC session using Xming or similar.

To clarify the issue, The company IT has the Windows server access sorted for us, the equipment and our little /28 subnet is our teams task to sort out, it has fallen to me. The Linux box has an X11 display for the desktop, that was done by the supplier, so I dont know why. When I look in the logs it keeps coming up with permissions issues. I have gone through everything I can think of, I have copied the magic cookies to where the XLaunch can see them, but still no joy.

The private network part means I dont have to use ssh forwarding with putty, it might simplify the troubleshooting if I take that out of the settings.

  • 1
    The way you've written this question makes it unclear what you're trying to accomplish. Please consider editing the question (not commenting here) to show more clearly the steps you're trying to do. It seems like there's some kind of jumpbox arrangement, but it's difficult to tell which is which. – squircle Apr 9 at 16:00
0

It turned out to be a service that was misconfigured, VNC now functional, please close

| improve this answer | |
  • Could you elaborate a bit more? What exactly did you do to resolve the issue? This way others may benefit from your experience. – dirdi May 13 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.