1

When I try the following command with FFmpeg (v. git-2020-03-24-e5d25d1): ffmpeg -i subs.srt subs.ass (subs.srt), I get a bunch of the following errors:

[srt @ 0000028ea78fa780] Invalid UTF-8 in decoded subtitles text; maybe missing -sub_charenc option
Error while decoding stream #0:0: Invalid data found when processing input

and:

[ass @ 0000028ea78ffe40] ReadOrder gap found between 3 and 4

I found that my .srt file contains the following char: ë I tried adding the flag -sub_charenc UTF-8 as stated here with no success.

How can I successfully convert .srt to .ass?

4
  • I can't duplicate the issue using e5d25d1. Please provide subs.srt.
    – llogan
    Apr 10, 2020 at 17:31
  • I've added the file, it's a hyperlink at the top of my post.
    – symonxd
    Apr 10, 2020 at 18:20
  • Try ffmpeg -sub_charenc ISO-8859-1 -i subs.srt subs.ass
    – llogan
    Apr 10, 2020 at 20:31
  • It worked, thank you very much. Take care yourself and others.
    – symonxd
    Apr 10, 2020 at 23:23

1 Answer 1

2

Try:

ffmpeg -sub_charenc ISO-8859-1 -i subs.srt subs.ass

I used uchardet to determine the character encoding:

$ uchardet subs.srt 
  ISO-8859-1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.