1

I just received a MacBook with a Hungarian keyboard layout from my workplace to work on. Hungarian keyboards don't have a specific buttons for backtick, they instead start the numbers on 0, so I wanted to find out how to type it.

As I could not find an answer on how to type it, I decided to remap right command to it, as I don't use this key at all anyway - using Karabiner.

Karabiner mapping Karabiner mapping

However even using this mapping, pressing does not produce a backtick, but this Hungarian character: í

Can you tell me a way to get a Hungarian Mac to produce a backtick character?

4
  • Try opt/shift/2 - that's what I get if I add Hungarian to my UK keyboard layout, though it starts as a dead key so I have to tap space if I want it alone. ` You can use the Keyboard viewer by adding it to the menu bar from keyboard prefs, or inside your language Input settings a smaller version of that. It's good for finding odd key-combos to dig out less common glyphs.
    – Tetsujin
    Apr 18 '20 at 10:57
  • Seems like Karabiner is mapping to where it thinks it ought to be on an ISO keyboard, the key left of Z. It's only left of 1 on an ANSI [US] keyboard.
    – Tetsujin
    Apr 18 '20 at 11:01
  • Hmm…I found it, but it moves, depending on whether you're set to Hungarian or Hungarian QWERTY. Hungarian, it's on opt/ű and on qwerty it's on opt/shift/í
    – Tetsujin
    Apr 18 '20 at 11:11
  • 1
    @Tetsujin Wow, it's really there on opt-ű. Thank you :) If you change your comment to an answer I'll accept it. Apr 18 '20 at 11:15
0

This took me a few minutes to track down, but tasks like this really benefit from using the Keyboard Viewer, accessible from the language menu.

Here, we find it lurking behind ü when you hold Opt ⌥

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.