0

Windows: Host

Arch Linux: Guest

I wanted to create a shared folder between Windows and Arch Linux, but I don't know why doesn't work because I can see the folder in /media in arch, but the files that copy there do not appear in the Windows folder

I did this

Device > Insert Guest Adittions CD Image...

I opened a terminal where Guest Addition ... and i run this

 sudo ./VBoxLinuxAdditions.run

next

 sudo pacman -S linux-headers virtualbox-guest-utils
 sudo systemctl enable vboxservice

then reboot and

Deivce > Shared Folder > Shared Folder Settings ... > (in the right) Add Share (i choose folder path and automount) > OK

next

useradd -m -G vboxsf pedro
sudo chown -R pedro:users /media/sf_Public/

i can see the folder in /media in arch but when i copy a file or whatever don't appears in windows.

0

1 Answer 1

1

Not sure if you still need the fix for this but i found the solution.

Once you have your user set up and you can see the shared folder, you need to change the permissions.

Your chown is incorrect.

You should use:

sudo chown -R yourusername:vboxsf /mount/point/of/shared/folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.