1

My cursor recently started to randomly switch to a cursor with the arrow on a mini scrollbar (see circled). Sometimes it is a vertical bar but sometimes it can be horizontal as well.

If I go to "Change pointer size and colour" and change the size/colour (and back), it goes back to normal for a while.

I have googled but most questions pertain to older systems and other laptops (mine is ThinkPad X1 2016). It seems to be a laptop touchpad driver issue, but I cannot find where to turn off "virtual scrolling" in my settings. I have disabled trackpoint but it doesn't seem to solve this issue either.

enter image description here


Mouse settings:

enter image description here

enter image description here

enter image description here

enter image description here

8
  • Do you have a mouse with a scroll wheel? Pressing the scroll wheel can do this.
    – DavidPostill
    Apr 19, 2020 at 11:10
  • @DavidPostill Yes, but when I tried to press the scroll wheel to see if it's the issue, the cursor changed to solid black up and and down triangles with a dot in the middle (with a black circle) like this cleanpng.com/…
    – xngtng
    Apr 19, 2020 at 11:14
  • Does this happen when you boot in Safe mode or Safe mode with Network? (If you can stay in it enough time.) Also try running sfc /scannow. See also this post and this one.
    – harrymc
    May 6, 2020 at 20:27
  • can you go to settings -> mouse -> additional settings (link on the right side): the 'Mouse Properties' Windows opens. Look at the pointer options. Also, see if there is a thinkpad-related specific tab. If necessary, add a screenshot to your question.
    – 1NN
    May 7, 2020 at 21:07
  • @harrymc thanks, it was ok in safe mode but its randomness makes it hard to really detect the problem. scannow didn't find any issue. I think ThinkPad changed the settings since I'm unable to find many of the options proposed by solutions online.
    – xngtng
    May 10, 2020 at 13:26

4 Answers 4

1
+50

If it doesn't arrive in Safe mode or Safe mode with Network, then this might be caused by some installed program or third-party device driver.

You might try first to update all drivers, especially mouse and touchpad, from the manufacturer's site.

If this does not help, to further locate the problematic application, you may use the free tool Autoruns for Windows.

This utility shows all programs configured to run during system bootup or login in its "Everything" tab. You may turn off startup items with a click and return them later with another click. You may avoid listing Microsoft products by using the menu Options > Hide Microsoft Entries, Hide Empty Locations and Hide Windows Entries

I would suggest turning off startup entries in bunches, drilling down to the startup program that causes this behavior. Once identified, it might have some setting that can avoid the problem, or can be left out of startup and only be invoked when required (verify that once invoked it does not add another startup entry, but such can again be disabled by Autoruns).

To short-circuit the process, start with products that relate to the mouse and touchpad.

1
  • Thanks, I've deliberately broken the touchpad driver and reinstalled it. I am also upgrading the system to the latest (which unfortunately breaks one of my webcams). So far it's been one and half days and it looks ok; but I'll see if it becomes a problem again.
    – xngtng
    May 13, 2020 at 9:28
1

Just disable the track point, I also had the same issue. and it worked for me

Mouse properties --> and disable the "Enable Trackpoint"

0

It might be related to touchpad gesture settings. Try opening Windows Settings - Devices - Touchpad, and fiddling with Scroll and Zoom options there. Touchpad setting screenshot

1
  • Thanks. Unfortunately, I don't have this setting on my laptop...
    – xngtng
    May 10, 2020 at 13:23
0

I had the same problem an it was fixed by disabling the touchpad when mouse is connected

1
  • This solved the issue.
    – st4co4
    Feb 8, 2022 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .