0

Edit: 27/04/2020

We came to the conclusion that the certificate stopped working as it does not work anymore on the old system either. So we keep working on "corrupted" certificates that may never ever work.

Case Closed

Original post:

I have this annoying issue which worked with the exact same way for multiple other users before but all of a sudden no longer works for this user. Short backstory. We migrate people from Windows 7 to Windows 10. They worked on a virtual floating machine and now get a laptop to work with windows 10.

So here is how I did it.

  • I went to IE -> Internet Options -> Content -> Certificates.
  • Selected all the certificates he has under Personal even tho I tried it even with doing it certificate per certificate for him.
  • Export
  • Yes, export the private key
  • Personal Information Exchange – PKCS #12 (.PFX)
  • Tried both with and without "Export all extended properties" but usually without
  • Set the password to "Password2020" (I know very creative but whatever)
  • Select a folder on Desktop as path

Now I move it to the new laptop. Going to the Certificates window again. Now I do:

  • Import
  • Select the certificate
  • Enter the password
  • Select "Automatically select the certificate store based on the type of certificate"

All the unimportant and expired certificates go to where they belonged. However all the valid certificates are under other people.

Is there any way to prevent this or anything that I can try to fix this issue? Would it work to remove them somehow? Because for some reason I cannot remove the certificates under other people. When I open IE with admin rights it doesn't show me any certificates. :C

With the words of Freddy Mercury "I'm going slightly mad".

Edit:

While looking online I found the Certmgr.msc and had a look arround in there. Now here comes the crazy part. All the certificates I imported over and over again are inside of the Personal and some were also under other people. However the certificates still don't all show up. What I see Any more ideas?

9
  • When you import the certificates. Where are you choosing to place the certificates? There are two certificate stores, one for the user, and the other for the machine. It also seems like if you should be installing some of these certificates when you create the Windows image. Have you considered that as an option? – Ramhound Apr 20 '20 at 14:31
  • @ramhound Trust me. Those certificates are no certificates that come with the Windows image. They are for a specific web application that doesn't open unless those certificates are installed. And yes I have selected the Personal folder also for some of my few attempts to import those certificates. – VarmintLP Apr 21 '20 at 5:50
  • I was suggesting you install those certificates then create a custom Windows image to use to install Windows instead of installing the certificates after Windows is installed. – Ramhound Apr 21 '20 at 11:16
  • @Ramhound sadly I can't just reinstall the laptop and then re-add the certificate to the profile which would basically not change a lot as the certificates are saved in the profile of the user. ^^' – VarmintLP Apr 21 '20 at 12:45
  • If you installed them to the machine, they would not have to install them to the user's certificate store, when the user was created on the machine, the certificates would already be there. – Ramhound Apr 21 '20 at 14:34
0

To close this issue and give people some possible ideas. What solved the issue for us was that we had to create a new certificate and import it/add it to the list. It took us some time as the certificate was for a special application that required two super admins to validate it but in the end it was the only solution as the certificate seemed to be "corrupted", not made for or not capable of an export on Windows 7 and import on Windows 10.

Or that certificate had some link to the machine itself or the user's SID (Example: S-1-5-21-1234567890-1234567890-1234567890-1234) and couldn't be imported by him since it was a new account in a different domain.

Hopefully this might be of some use to someone else.

0

I had the same problem with user certificate which was installed to Other People. The root certificate of the authority expired and I had to install new root certificate (SIGEN-CA G2) to the Intermediate Cartification Authorities.

2
  • 1
    as a reviewer, I don't know the context and won't vote up since I don't know if this helps others; still, I'd like to thank you for sharing your experience, that's the core value of the community! – YakovL May 16 at 13:48
  • Same from me. If I was still at that company / customer, I would try to give it a try to see if it would have solved the issue in retrospect. However it may be useful to somebody else. – VarmintLP May 27 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.