0

If I use smbclient from the command line on a unix host to access a windows server share (happens to be a windows server in an Active Directory domain), it works fine. I can access directories and files on the server. Here's the smbclient command that succeeds:

smbclient -U user -W domain -I ip_host //sharetop

So now I am trying to use tramp mode in emacs to open (find-file) the following url:

/smb:user%domain@ip_host:/sharetop

I get a password prompt as expected:

Password for /smb:user%domain@ip_host: 

However, when I enter the correct password (same one that works with smbclient), it just shows me the password prompt again. And the *Messages* buffer has:

Tramp: Opening connection for //user@ip_host/sharetop...failed

I'm looking for success stories with emacs tramp mode accessing files on smb urls that point to windows servers. Or perhaps a way to get more information than just "failed".

Update
I set tramp-verbose (Traces) to 6, and that showed the smbclient command line:

smbclient -g -L ip_host -U user -W domain -s /dev/null

-L is intended for the netbios name. In my case, I am using an IP address or DNS name. So, it appears I'll have to figure out how to convince tramp/smb to accept an IP address instead of a netbios name.

0

Well, Tramp needs the -L parameter in order to apply also -g, grepping for the existing shares. Using -I would make it much harder to see the shares. Possible, but not implemented yet.

I recommend to write a feature request (aka bug report) either to the Tramp mailing list, or as Emacs bug report.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.