0

EDIT: I answered to myself. Read it below this post.

I bought a new laptop, MSI GV62 7RC, and installed the latest Win 10 1909 from scratch and fully updated it.

I right click This Computer and go to Computer Management -> Services where I disable the automatic start of the SysMain service (it's responsible for preloading frequently launched applications' data and was formerly known as Superfetch). However, it is re-enabled every few reboots.

Never before have I encoutered such behaviour. On other PCs, when I disable the SysMain service, it stays that way.

How do I keep it disabled?

  • What version are the other machines running? – Ramhound Apr 23 at 21:43
  • The same Win 10 1909, fully updated. – daerragh Apr 23 at 21:45
0

OK, I know what happened.

It turns out that the SysMain service is needed for the Windows 10 Memory Compression feature to work. I didn't know that. So when I disable the SysMain service (it disables the Memory Compression too), and then go to PowerShell to enable the Memory Compression (enable-mmagent -memorycompression), it enables SysMain, too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.