My Fresh kali Linux install doesn't find pip and so i can't run my scripts. So here is what i tried:

kali# pip -V
Command not found

kali# whereis pip 

kali# locate pip | grep /usr/bin

kali# apt-search python-pip

kali# apt install python-pip-whl
python-pip-whl is already installed

I also tried to add ubuntu repos with the package python-pip. But didn't work. Sooo….yeah. Nothing really helps. Can somebody plz help me? I use kali for like one year and this is the first time this happens to me :D What am i missing? Somebody can explain to me? Thx in Advance.

2 Answers 2


Python 2 went end-of-life on January 1, 2020. According to this article, Debian (and Kali as a downstream consumer) will be removing Python 2 packages. While Python 2 pip is not explicitly discussed, it's entirely likely that's why you can't find it.

Instead, you can apt install python3-pip and use pip3 to install packages for any coding you do, which should be in Python 3 rather than Python 2.

  • Thx a lot!.. My bad :)
    – Lukas Räpple
    Apr 24, 2020 at 19:43

If pip not found, try these commands:

  1. sudo apt install python3-pip
  2. pip3 install -r requirements.txt
  3. /usr/local/bin/python3.10 -m pip install --upgrade pip