0

Last night I unplugged my wireless USB headset receiver from my computer, and one of my monitors disconnected and will not reconnect. So far I've done some troubleshooting including:

  • Restarting my computer.
  • Using a different port on my graphics card. They are all confirmed working with two different monitors.
  • Using a different input on the monitor.
  • Switching out all cables/adapters. Again confirmed working with the same two different monitors.
  • Testing the monitor with a different computer. It is confirmed working.
  • On Windows 10, going to the device manager in the control panel and uninstalling/reinstalling my graphics card.
  • Power cycling the monitor.
  • Updating drivers.
  • Switching to Linux Mint 19.3. Still no picture.
  • Using a fourth monitor. My computer did not detect this one.

After doing all of the above my computer will not detect the monitor and I am at a loss of what to do next. For reference I am using an Nvidia GTX 1660 Ti with driver 26.21.14.4587, and the port I was using for the receiver was on an internal PCIE add-in card. My graphics card has 3 display port ports and one HDMI and I was using a generic HDMI to display port adapter for the monitor.

Thanks in advance for any help or ideas.

0

If all of the hardware links have been tested independently, and you can't find/enable it in the display manager's Display settings, maybe X has done something funky to the config relationship. Does it show the monitor connected with a mode set when you run xrandr?

You could try

xrandr --output [port_name] --auto --brightness 1

Which should turn it on if it's just been --offed somehow, and make sure brightness is up. If it shows up, lists modes, but doesn't have one starred, you might have to do xrandr --output [port] --mode [resolution]

or xset -dpms to turn off any power management stuff that could be strange on this hardware

Also check your /etc/X11/xorg.conf, /etc/X11/xorg.conf.d/, and /usr/share/X11/xorg.conf.d/ for anything strange.

I think I also once had a problem where I've had to re-add the xrandr mode entirely to make a monitor work, there's a guide to doing that here if you want to try it, but usually adding a mode to a port listing none is usually only used for making virtual screens.

But to be honest none of that shouldn't be fixed by switching distro, unless it's being caused by a config file or partition you're keeping between them

Have you tried running a graphical session as the root user, seeing if that makes a difference?

good luck!

1
  • For reference I primarily use Windows 10 and have used Linux for about a month, but I'm working through that guide you linked to try and get the monitor detected in Linux. I got to the "addmode" step and got a BadMatch error, and I'm still working to resolve that. – jerrythesphere Apr 25 '20 at 14:51
0

The problem was a bad HDMI cable. I should have been more thorough in my basic troubleshooting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.