0

OS: Windows 10 64 bit 10.0 Build 18363

After recent windows update .NET v4 frame work using software's stopped working.

enter image description here

While trying to install the v4.8 or 4.7.2 .NET framework Getting the message saying its already installed.

enter image description here

Tried enabling .NET extensibility and restarted the PC. Again getting same set of errors.

enter image description here

Found this link from more info in the blocked installer

https://docs.microsoft.com/en-us/dotnet/framework/install/troubleshoot-blocked-installations-and-uninstallations

Tried .NET installation repair tool kit, and tried installation of .NET framework. Still didn't worked.

Tried the answer of How to reinstall .NET Framework 4/4.6 on Windows 10?

Still looking for new steps or a new repair tool from Microsoft to fix installation of .NET v4x in windows 10 18363.

7
  • I suggest doing Repair Install of Windows 10 with an In-place Upgrade.
    – harrymc
    Apr 25 '20 at 18:32
  • .NET Framework 4.8 is already installed on the current version of Windows 10, which means .NET Framework 4.0 cannot be installed, since 4.8 is an in-place upgrade to 4.0. Your Windows installation is corrupt and you should do an in-place repair installation.
    – Ramhound
    Apr 25 '20 at 23:37
  • “Still looking for new steps or a new repair tool from Microsoft to fix installation of .NET v4x” - It is impossible to install or repair the .NET Framework 4.8 installation. Your only solution is to do a repair installation of Windows
    – Ramhound
    Apr 25 '20 at 23:39
  • 1
    Does this answer your question? Completely missing Dot Net in Windows 10 -1909? or this
    – Ramhound
    Apr 25 '20 at 23:41
  • @Ramhound Trying commands in the first link didn't work after commands execution and restart. For the 2nd link all update in the laptop were not installed successfully, on restart I see message 'We couldn't complete the updates Undoing changes Don't turn off your computer Your organization manages your update settings'.
    – Mcore8x
    Apr 26 '20 at 10:05
0

Thanks to @Ramhound for 2nd link

Requested system administrator to allow windows update for the PC and new feature update through complete windows update enabled the .Net framework v4.8 in Window 10 Build18363 . Now All the applications that were throwing error is working now.

Also observed in the 'Turn Windows Features on or off' window. Its named as '.NET Framework 4.8 Advanced Services'.

This was '.Net Extensibility 4.8' before latest windows update.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.