Is there a way to refresh the current configuration used by modprobe with an updated modules.conf file at the command line for Red Hat Linux 9.0?

  • I presume you mean to update modules.conf, and then want a command which will apply it to the currently running system without rebooting (since rebooting will use the new modules.conf anyways). Is it an issue of not knowing which modules changed and need to be modprobed? Jun 20, 2010 at 2:10
  • Yes, that's it. I'm trying to add an eth1 alias for a wireless network driver that uses wlan0 as its interface, but it's not behaving the way I expect it, and I have to keep rebooting to see the results of my different experimentation. Jun 20, 2010 at 2:29

2 Answers 2


If you're just testing modules out, you should be able to use modprobe <module> and modprobe -r <module> to insert and remove modules from the linux kernel, respectively. insmod and rmmod should also perform the same functions (inserting and removing).


It sounds like you're looking for the mapping directive in /etc/networking/interfaces. See man interfaces for details on how to alias networking devices. Note that terminology-wise, an "alias" is a second, third, or otherwise additional IP for an IP device, resulting in an interface with multiple IPs. A "mapping" is used to map logical interface names (ifconfig LOGICAL_INTERFACE up) to real interface names.

  • Thanks, I already know how to do that. The problem that I am having though is when I have the line <i>alias eth1 rt61</i>, it loads the modules on boot, but when I try to bring up the interface using <i>ifconfig eth1 up</i>, it returns <i>eth1: unknown interface: No such device</i>. So I've been trying to play around with the alias and options in modules.conf to try to get the interface up. Jun 20, 2010 at 8:10
  • @xolstice The alias options in modprobe.conf do not have anything to do with ethernet interfaces, and the configuration file is always used by modprobe with whatever latest edits you've made. If you're trying to make your system re-detect your network card (and re-attempt to load kernel modules for it), then you need to look into hardware detection (recent distros use udevd, but RHL9 is far from recent). If you're trying to alias the name of your interface (to use ifconfig eth1 instead of ifconfig rt61, then check out networking (/etc/network/interfaces, or man interfaces). Jun 20, 2010 at 10:06
  • @xolstice See edits to answer. Jun 20, 2010 at 10:09

Old question but I think it can help someone who find an answer. In systemd modules loads with service systemd-modules-load. You can check status with command:

sudo systemctl status systemd-modules-load.service

or reload modules with command:

sudo systemctl restart systemd-modules-load.service

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .