0

I bought a second-hand HP Z820 workstation. Upon turning it on for the first time, Windows 10 installed and everything works smooth. The machine has two storage devices: a 512GB SSD (slot 0) and a 2TB HDD (slot 1). It also has two additional empty slots (2 and 3). The SSD is primary and has Windows 10 on it.

I bought a 2TB SSD and a 3.5" caddy for it and tried to add that in slot 2. It does not appear in BIOS or Windows. I also tried to swap slots with the HDD. Now the HDD shows up in slot 2, but slot 1 appears empty.

The disk works. I have a small SATA to USB adapter and I have initialized and read/written to the disk on a different computer. The caddy also works.

Somewhere I read it could be the SATA mode. In the BIOS, SATA mode is set to "RAID+AHCI". I could change that to "AHCI" or "IDE". Should I try that or do you have other ideas?

1
  • 1
    You should absolutely NOT switch your boot mode unless you want to reinstall Windows. – Ramhound Apr 27 '20 at 15:50
1

As I see in spec, you could have LSI MeagRAID controller, which is hardware RAID.

To start using your new disk you should enter RAID BIOS (there will be hint on screen like "Press Ctrl+I to enter MegaRAID bios" or it could be accessible from system BIOS).

Then you need to create new logical volume and add new disk there. Then your system will see it.

Great workstation by the way.

1
  • Thank you. I don't believe I have that specific LSI but regardless it's a pretty sweet toy. Now I have two spare 500GB SSD's and your answer gave me the idea of using them as RAID :) – Mattia Landoni Apr 29 '20 at 5:49
0

Sadly, the problem was that the SATA port wasn't properly connected into the 3.5" caddy. I found out by swapping caddies. These things do happen!

1
  • Glad it resolved. – p0rc0_r0ss0 Apr 30 '20 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.