My Windows 10 1909 is in English (Canada) and my keyboard is in Canadian french. When I write my PowerPoint they are in French, but it keeps changing the proofing language to English.

Here's are my language setup in PowerPoint. As you can see, my settings seem ok

I've followed this answer, but it seems to work with Windows 7 and PPT 2010.

  • Try this: Press Alt+F11 to open the VBA editor. Press Ctrl+G to open the Immediate window. Type this into the Immediate window: ActivePresentation.DefaultLanguageID = As soon as you type the = sign, the editor will show you all the available language choices. Choose the one you want for your presentation, then press ENTER. See if that helps. Note that when you change this setting, it'll remain until you change it to something else. I just noticed that as the result of some tests I did days ago, my copy of PPT was set to Basque. No wonder I've felt confused for the last few days. Jul 30, 2020 at 17:21

1 Answer 1


Sadly, there are many different possible reasons. It looks like anything other than Windows display language, Windows region, Office display language, Office default editing language, keyboard language and intended editing language all matching has the potential to create problems.

Some possibilities include:

  1. Wrong slide master language. Go to View > Slide Master. Select the parent style, select all text boxes (e.g. with Ctrl+A). Then change the proofing language in Proofing/Review > Language.

    In my case, new documents are always in German despite the editing language being set to English. I suspect that the "Language Accessory Pack" for the intended language must be installed to get the intended behavior, which cannot be installed on all systems; The Download page offers only an .exe installer, which then complains about being incompatible with .msi based Office installations; On a workplace PC, this may not be fixable. When using a corporate template, it doesn't matter though, since the language apparently needs to be set in the template.

  2. Keyboard language. Some programs may use your systems keyboard language as the proofing language of newly typed text. Note that windows allows configuring any combination of keyboard language and keyboard layout. I for instance use "English (US)" with a German layout.

  3. Editing language. Check the settings under File > Options > Language. For me changing the default language had no effect in Powerpoint though, new slides still start out with the slide master in German, when I want English.

    I think this is what you show in your screenshot, so I guess you're making the same experience here as me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .