0

I just bought an old IBM X3650 M2 and installed Ubuntu Server 20.04 LTS. My router (Netgear R7000) is not obeying the IP rules I set in the router setup (and so far, I've only noticed this for this "new" server, not for the other 67 devices where I have previously assigned IPs in the router DHCP).

In the IBM server configuration, I enabled the network (IPv4), and checked the "DHCP" option.

My router assigns a random IP (192.168.0.5). I then assign an IP address in the router config (192.168.0.99) and apply. Once the router finishes restarting the DHCP, the server is now at 192.168.0.2. Rebooting the server (even power cycling) or re-assigning the IP and re-applying doesn't change anything.

It seems the router is allowed to assign IP to the server, but the router won't obey its own rules. The rule is displayed loud and clear in the router config, it's not dissapearing (as I've seen other posts complain about).

I know (think?) I could just assign a static IP in the server config, but I'd rather have it done by the router, for various reasons. And the question "why is it doing this?" is also bugging me :)

Cheers!

EDIT: I tried setting a static IP in the BIOS setup of the server. First time it worked (my testing IP, 192.168.0.99), but when I tried changing it to the permanent IP I need to use (192.168.0.100), it reverted back to the router appointed (.2) address. What more is, I can no longer set it back to the "testing IP" (.99).

In the router, the change I made between being able to assign IP in BIOS setup and not, was to delete the entry for my old server (just an old NUC type computer, really), which was previously at 192.168.0.100.

  • 1
    Without seeing the router config it is going to be nearly impossible to answer, but my first guess is that the static assignment you made in your router does not point to the ubuntu server, and as such, the ubuntu server gets a fresh ip upon renewal. Doublecheck the MAC Address of the network port of your server and ensure that same mac address is in your router config. It should then work. You can also see on your router under leashes, which leash is static and which is dynamic. – LPChip Apr 30 at 20:21
  • That was also my first assumption; it seems like it dishes out dynamic IPs like there's no rule for the specific MAC. But the MAC is correct (the router automatically displays any devices not already assigned static IP in router DHCP when adding new rule, you just have to click the device you want to set a rule for). I even re-created the rule several times, and tried assigning a different IP a few times. I did also quadruple check that the MAC of the connected server (at 192.168.0.2) is the same as what I assigned IPs. They are identical. – Aephir Apr 30 at 20:43
0

From both personal experience and anecdotal evidence online, Netgear firmware has a pretty unstable relationship with DHCP (e.g. [1] [2]). So in answer to the question "why is it doing this", the answer is highly likely to be some kind of firmware issue and very unlikely to be your fault. You can certainly assign a static IP in Ubuntu Server without any problems (provided there are no conflicts with other network devices). The only downside to this is not having centralised IP address management - I use DHCP reservations for all servers on my network to make things easier for me.

A few thoughts/suggestions:

  • What, if anything, was previously at 192.168.0.2? Is this a rare instance of MAC address conflict with another reservation?

  • On some routers, DHCP reservations need to be outside the DHCP address pool. So if your current DHCP pool range is .2-.254 then try changing it to .2-.90 and see if your .99 reservation sticks.

  • The only other solution I have seen is to roll back to an older firmware version (which is the solution in many of the forum threads you can find online. The problem with this approach is that firmware updates often fix security issues and rolling back may make your router (and by extension, your network devices) more vulnerable to attack.

| improve this answer | |
  • 1
    Thanks, nice to know (think) that I'm not going crazy. I haven't had anything assigned at [.2], but I took note of an unknown device occupying this address a while back. A MAC lookup showed Alpha Networks Inc., but no idea what it was. This router needs the assigned IP to be WITHIN the DHCP range (which I set to .2-.254). Darn... I just tried changing that to .3-.254, and after applying, it assigned the correct IP! Thanks :) – Aephir May 2 at 17:33
  • Great to hear it's working now! Thanks for coming back to confirm :) – Unencoded May 3 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.