0

I have a WS C422 Sage/10G motherboard which supports two M.2 slots. I got 2x Inland Premium 1TB SSD 3D NAND M.2 2280 PCIe NVMe 3.0 x4 Internal Solid State Drives to go into those slots. According to the motherboard specification, both M.2 slots support 2280 type drives, so I assumed both would be compatible. I installed the drives into the two slots on the motherboard, one of which is an upright slot, and the other is a flat slot with a standoff.

However, when I live boot the workstation (use Arch Linux Live CD) and give the fdisk -l command, it is only showing one of the drives as /dev/nvme0n1. The other drive is not listed.

I suspect it may be a hardware problem, because when I go into the BIOS, the list of boot devices only has one "PCIe SSD" listed, not two.

I have SATA set to ACHI (the default) in the BIOS.

How can I further diagnose this problem?

2
  • Do the devices show up in lspci? Have you tried swapping them, or connecting only one?
    – user1686
    May 2 '20 at 16:51
  • @user1686 That just shows one NVME controller. See my update in the question, the BIOS is only listing one of the drives in the boot device selection, so the BIOS is not seeing the drive. May 2 '20 at 17:51
1

After carefully re-reading the motherboard manual I found out the problem which was that the upright M.2 gumstick was not seated properly. This motherboard uses an unusual seating bracket to hold the drive card and secure it in the socket. After installing this sled-like bracket and re-seating the card it worked. I have shown an excerpt from the manual from p. 2-11 for reference so you can see what the bracket looks like:

enter image description hereenter image description here

To install this bracket, a jeweler's screwdriver is needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.