0
  • OS: Windows 10 Build 18363
  • Laptop: Acer Aspire E5-475
  • SSD: Samsung 970 EVO Plus NVMe M.2
  • BIOS mode is UEFI

So following instructions on various websites, I installed my new SSD on my laptop. I used the Samsung Data Migration tool to clone my old HDD into the new SSD. I then changed the boot order in the BIOS and made sure the SSD was first.

In my first attempt, I didn't unplug my HDD which was apparently wrong. So I deleted everything on the new SSD with diskpart, and ran Samsung Data Migration again. This time, I unplugged the HDD and successfully booted into the SSD.

Seeing that I successfully cloned and booted into the new drive, I plugged the old HDD back in. When I turned my laptop on, I was back on the old HDD (I know because capacity is 1TB vs 250 GB for the SSD). I went back to the BIOS to check boot order, and SSD was on top.

What did I do wrong? Did I skip a step?

EDITED TO ADD I think I was able to narrow down the problem but I'm unsure how to resolve it. I enabled the boot menu through the BIOS and saw that Windows Boot Manager was the only option and it seems to only be on the old HDD.

5
  • try swapping the cables. if there is no boot order configuration in the bios that indicates which disk specifically to boot from, it will boot off the first disk on the first sata control that has a bootable configuration like an MBR. May 3 '20 at 4:51
  • @FrankThomas Correct me if I'm wrong but since this is an M.2 SSD I don't think there's a cable to swap?
    – Paolo
    May 3 '20 at 5:12
  • yeah that does make it harder... May 3 '20 at 5:36
  • See if this thread helps.. superuser.com/questions/1535225/…
    – patkim
    May 3 '20 at 6:00
  • @patkim Thank you! I posted an answer adapting the answer there.
    – Paolo
    May 3 '20 at 7:19
1

Following @patkim's lead in the comments, I followed the steps outlined here. But since I couldn't see the SSD if my PC booted into the old HDD, I booted into my Windows 10 install USB and used the command prompt from there. I ran bcdedit and, like in the linked answer, saw that it still pointed to the old drive. So I typed the following commands (my new SSD was showing up as F and not E like in the linked answer):

bcdedit /set {default} device partition=f:
bcdedit /set {default} osdevice partition=f:

After that I was able to boot into Windows on the new SSD and used diskpart to clean the old drive and use it as extra storage.

0
0

I may be understanding this wrong, but you're saying the HDD was 1TB and the SSD was 250GB? That may be one of the issues. When cloning both drives your new drive must be equal to or larger in storage space than your old HDD. The partian may not be cloning properly. Also depending on the motherboard of your pc, there may be two areas where you can determine boot order. A section called BOOT and a section called Hard Disk BBS Priorities. If you have these two categories, while both categories may have a boot option 1, 2, 3, 4, I've observed that Hard Disk BBS priorities will determine for what hard disk you can set for boot order in section BOOT. For instance if you have Boot Option 1 which is linked to the HDD in Hard Disk BBS Priories, then you can set that hard disk in any Boot option slot in the section called BOOT. By the way Boot option 2, 3, 4, etc in Hard Disk BBS priorities will allow the motherboard to read the hard drives as for instance a storage device. Should you disable any of Boot option 1, 2, 3, slots. The hard drives won't be recognized by the motherboard, and in the BOOT section you won't be able to set your specific hard drive in any of the options. if you have a section called Hard Disk BBS Priorities, i'd try setting the SSD to boot option 1 and if the HHD is moved to option 2 then disable boot option 2 so nothing shows. Then in the BOOT section, set that boot option to the SSD. If you can boot the SSD then that means you can keep the HDD plugged in. Also after confirming, then in the Hard Disk BBS Priories section set Boot option 2 back the HDD instead of blank, and see if you can boot from the SSD. Also make sure the HHD is not listed in any boot options in the BOOT section. I hope this helps. I'm not sure of Asus's bios structure, but there should be something similar. Here are some images for reference. Boot Category 1 Picture Boot Category 2 Picture

3
  • From what I've read, cloning should still work if the actual space used on the larger drive is less than the smaller drive's capacity. In this case, I was only using about 80GB of the 1TB drive. Also, I don't see a section called Hard Disk BBS Priorities in my BIOS. I edited my question to add more details.
    – Paolo
    May 3 '20 at 4:00
  • On Asrock boards, there is a section in BIOS/UEFI that lets you override boot order for that particular boot-up instance. Try selecting the correct entry and booting from that BIOS screen? Actually I'm not even sure where @TheDataProcessor got Asus BIOS from, as it looks like you have an Acer board. I'm not familiar with them myself, but you might want to try reviewing the documentation for your model here.
    – Arctiic
    May 3 '20 at 4:27
  • I forgot to add details when i made some edits on my previous post. And Asus was a typo. I was thinking acer but typed asus. I typed my response on 2 hours of sleep and 5 cups of coffee. Sorry. But yeah what I wanted to say is that some boards have secondary category for boot settings in the bios but it all depends on the model and maker. May 3 '20 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.